Bug Hunting Session
Bug 90125 - MAILMERGE: merged document looses all enumerations
Summary: MAILMERGE: merged document looses all enumerations
Status: RESOLVED DUPLICATE of bug 89214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: lhm-limux
Keywords: bibisected, bisected, regression
Depends on:
Blocks: 62364
  Show dependency treegraph
 
Reported: 2015-03-20 08:58 UTC by Jan-Marek Glogowski
Modified: 2015-12-17 08:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Minimal bullet point document, originally used to test bug 62364. (9.60 KB, application/odt)
2015-03-20 08:58 UTC, Jan-Marek Glogowski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan-Marek Glogowski 2015-03-20 08:58:16 UTC
Created attachment 114204 [details]
Minimal bullet point document, originally used to test bug 62364.

Mailmerge the attached document with any data source.

All enumeration formating in the target document are lost.

I bisected the problem in our 4.1 branch in private/jmux/libreoffice-4-1-6+backports~40 .. private/jmux/libreoffice-4-1-6+backports, which pointed to 224f9aebac7c1582c3faf836eeec12452b969d19

aka

commit bb00a0097900ae054401f7758a915047cfde4065
Author: Luboš Luňák <l.lunak@collabora.com>
Date:   Sat Nov 8 09:41:02 2014 +0100

    do not bother with nice unique names during mailmerge
    
    When using a single document for all the generating MM documents, there can
    be a significant number of sections/etc. , enough to make searching them
    all in order to find a next nice unique name take a noticeable time. Since
    it's very unlikely anybody will ever care about nice names after mailmerge,
    just get some unique name in a fast way.
    
    Change-Id: Id6b8d39a67529984cb93bb369f2c6eab401f1799

I wanted to do a bibisect on master, but the current download rate of the 44max repo was just 100 kB => ~30h download. So I can't rule out the possibilty it's an other problem on master.
Comment 1 Matthew Francis 2015-03-22 04:37:32 UTC
The above is a perfectly good result, and the behaviour of the attached document changes at exactly that point on master. (Somehow this commit seems familiar, but I can't find another bug that references it, so...)

Adding Cc: to l.lunak@collabora.com; Could you possibly take a look at this? Thanks
Comment 2 Matthew Francis 2015-03-22 04:42:52 UTC
Ah, my mistake, there is a previous report after all. I wonder why my search didn't pick that up the first time...

*** This bug has been marked as a duplicate of bug 89214 ***
Comment 3 Jan-Marek Glogowski 2015-03-23 10:01:40 UTC
(In reply to Matthew Francis from comment #2)
> Ah, my mistake, there is a previous report after all. I wonder why my search
> didn't pick that up the first time...
> 
> *** This bug has been marked as a duplicate of bug 89214 ***

Well - I didn't find this bug too :-)
I'll just add the blocker to the main bug.
Comment 4 Robinson Tryon (qubit) 2015-12-17 08:49:36 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]