Bug 90142 - Recovery gets to the point of "successful". After "Finish" is pressed, Writer aborts.
Summary: Recovery gets to the point of "successful". After "Finish" is pressed, Writer...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 90143 (view as bug list)
Depends on:
Blocks: Document-Recovery
  Show dependency treegraph
 
Reported: 2015-03-21 08:30 UTC by Paul Roos
Modified: 2022-10-09 03:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File that causes problem. (401.89 KB, application/vnd.oasis.opendocument.text)
2015-03-21 08:30 UTC, Paul Roos
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Roos 2015-03-21 08:30:52 UTC
Created attachment 114228 [details]
File that causes problem.

Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: en_ZA

The last thing I did to the document, was a paste of an image to a table row.

The recovery completes. When finish is pressed, Libre Writer bombs out.  I see something flashed .. SEH(?) error.
Comment 1 A (Andy) 2015-03-21 08:40:52 UTC
*** Bug 90143 has been marked as a duplicate of this bug. ***
Comment 2 Geoffrey 2015-03-21 10:14:09 UTC
I can confirm the crash with LibreOffice 4.4 on Manjaro Linux.
Comment 3 Paul Roos 2015-03-22 06:19:25 UTC
I found a workaround:
(1) Open the file with Wordpad (on Windows)
(2) Save the file as a *.rtf file.
(3) Open the *.rtf file with Libre Writer.
(4) I found a table that was screwed, so I fixed it.
    It seemed as if the table embedded another table.
(5) Save it as a *.odf file. (I used a new name).
The full contents was there.

The last thing before the original crash, I did a change to a table.

Thanks for your time. At least you guys know there is a problem and 
the problem area is when a table is being edited, likely on insert 
within an existing table.

Regards,
Paul Roos
Comment 4 QA Administrators 2016-11-08 12:09:09 UTC Comment hidden (obsolete)
Comment 5 david.fraser 2017-08-11 16:23:50 UTC
I have found the same or a similar bug with LibreOffice 5.2.5, 5.3.5, and 5.4.0 (Win_x64 or Win_x86), using Windows 7 Professional 2009 64-bit version with Service pack 1, or Windows XP Professional 2002 SP 3, respectively.

This is with a Writer document about 3 MB in size, 118 pages. It has several tables already, and opens and can be edited OK. I then select a space with just a two or more lines, and copy and paste a 2x7 table with text into that space, or create a new table and then enter text into the table. I save the file with a new name: filename.odt.  The file seems to save OK.  I close the file. When I try to open the new file, the file opens, and the cursor line blinks a few times on the first text and then the cursor line remains fixed, and I also see a spinning blue circle.  When I try to do anything else such as click anywhere, or go to another page, I see the message "Not Responding", and the file image becomes semi-transparent (or faded).  When I close the message, the file is still not responsive, and "Not Responding" is added to the file name on the title bar.  When I close the file, I see a new file ".~lock.filename.odt#".

If Windows Explorer is sorted by Date Modified, and a ".~lock.filename.odt#" file is a more recent file, then when I try to open any Writer file in the same folder whether there is a corresponding ".~lock.filename.odt#" or not, I see a LibeOffice (e.g.:) 5.4 Document Recovery window with a list "Status of recovered documents" showing documents and Status = "Not recovered yet".  I have to discard each document in this list, and then I can open the Writer file I want.  If I then open any of the files discarded, it just shows Not Responding and creates a ".~lock.filename.odt#" file again.

I have tried several partial workaround attempts, such as creating a new 2x7 table in the desired location, but not entering text, and the file saves OK, and I can close and open the file and move around in the file.  But when I entered text into the newly created table, save and closed the file, and opened the file again, it is now Not Responding.  In one case instead of creating a new table, I just inserted 30 new lines in the desired location, save, closed, and opened the file - now Not Responding.

Noting the previous report, I checked that I am not inserting a table into an existing table by moving the cursor along the left edge of the page to see if would change to a black arrow pointing diagonally down indicating an existing table.  I made sure that the cursor did not show this when I created or pasted any tables in my above description.

The above description is reproducible, but various workaround attempts are not always predictable whether the file will become Not Responding.
Comment 6 QA Administrators 2018-10-08 02:47:41 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2020-10-08 04:08:22 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2022-10-09 03:50:16 UTC
Dear Paul Roos,

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from https://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://web.libera.chat/?settings=#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug