Bug 90154 - Visio Drawing incorrect overlappings
Summary: Visio Drawing incorrect overlappings
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libvisio (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-22 09:08 UTC by Maarten Hoes
Modified: 2017-10-30 11:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Microsoft Visio Drawing (601.00 KB, application/vnd.visio)
2015-03-22 09:08 UTC, Maarten Hoes
Details
Screenshot of Visio document opened in Microsoft Visio (103.35 KB, image/png)
2015-03-22 09:08 UTC, Maarten Hoes
Details
Screenshot of Visio document opened in LibreOffice Draw (109.84 KB, image/png)
2015-03-22 09:09 UTC, Maarten Hoes
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Maarten Hoes 2015-03-22 09:08:03 UTC
Created attachment 114238 [details]
Microsoft Visio Drawing

When opening the Visio attachment to this report in LibreOffice Draw, in the top right and left corners (and some in the middle as well) there is text (the word 'data') that incorrectly overlaps the objects (see screenshots). This text doesnt show up when opening the file in Microsoft Visio.
Comment 1 Maarten Hoes 2015-03-22 09:08:53 UTC
Created attachment 114239 [details]
Screenshot of Visio document opened in Microsoft Visio
Comment 2 Maarten Hoes 2015-03-22 09:09:18 UTC
Created attachment 114240 [details]
Screenshot of Visio document opened in LibreOffice Draw
Comment 3 Buovjaga 2015-06-25 12:20:21 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: a51ac4d2bb8c4f1ea1d4ea7569863e2fb6535b02
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-06-22_21:37:53
Locale: fi-FI (fi_FI)
Comment 4 Fridrich Strba 2015-12-14 02:33:18 UTC
This commit in libvisio
http://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=037e82fcaaacb3b6b68e54f424398e7260d64a62
fixes the "overlapping". It was basically a bug in handling of stencil text.
It will take some time before this reaches the LO users (libvisio release + integration), but I set it to fixed since I fixed it :)