Bug Hunting Session
Bug 90185 - MAILMERGE: crash just as mailmerge begins to send the first email
Summary: MAILMERGE: crash just as mailmerge begins to send the first email
Status: RESOLVED DUPLICATE of bug 89214
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks:
 
Reported: 2015-03-24 01:29 UTC by Mark Appier
Modified: 2016-06-12 19:48 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
*.odt file from which I was trying to send emails. (17.18 KB, application/vnd.oasis.opendocument.text)
2015-03-24 01:29 UTC, Mark Appier
Details
console bt with master sources (9.33 KB, text/plain)
2015-03-24 20:39 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Appier 2015-03-24 01:29:32 UTC
Created attachment 114289 [details]
*.odt file from which I was trying to send emails.

Yesterday, I upgraded LibreOffice to Verision: 4.4.1.2 Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432 Locale: en_US being run on Windows Vista As I have done a large number of times with previous builds, I typed a short email to send to all of our school students, parents, and patrons. A list of all of the emails was extracted out of our SIS (School Information System) which I then pasted into Calc and saved as All_Emails.ods. As normal, loaded the data sorce, LO constructed the merged file (nothing to merge as I am sending the same message to everyone), selected the appropriate field from which to send the emails (the only one), and pressed the send button. The sending dialog box came up for a few tenths of a second, then LO crashed (not the Mailmerge dialog box). If I ignored the "Save for Recovery" dialog, the Mailmerge window behind it indicates that the sending of emails was paused right before it began sending.

Moving over to the secretary's computer running Version: 4.3.5.2 Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5 on Windows XP, using exactly the same files copied from the Vista machine, the system worked perfectly, and the emails were sent.

I played with it again today with a fresh writer file, and got the same results. Our IT administrator on campus recommended that I file a bug report

So, is it possible I am doing something that would cause it to hang at this point?

I have attached the *.odt file from which I was trying to send the emails. Due to FERPA concerns, I cannot attach the actual spreadsheet containing the emails.

Sincerely,

Mark Appier
Comment 1 Julien Nabet 2015-03-24 20:39:57 UTC
Created attachment 114312 [details]
console bt with master sources

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 Matthew Francis 2015-03-30 08:57:51 UTC
This appears to have been introduced by the below commit.
Adding Cc: to l.lunak@collabora.com; Could you possibly take a look at this? Thanks

(To reproduce, mail merge the attached document from a blank database, and send by email)

commit bb00a0097900ae054401f7758a915047cfde4065
Author: Luboš Luňák <l.lunak@collabora.com>
Date:   Sat Nov 8 09:41:02 2014 +0100

    do not bother with nice unique names during mailmerge
    
    When using a single document for all the generating MM documents, there can
    be a significant number of sections/etc. , enough to make searching them
    all in order to find a next nice unique name take a noticeable time. Since
    it's very unlikely anybody will ever care about nice names after mailmerge,
    just get some unique name in a fast way.
    
    Change-Id: Id6b8d39a67529984cb93bb369f2c6eab401f1799
Comment 3 Robinson Tryon (qubit) 2015-12-13 11:12:17 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 4 Robinson Tryon (qubit) 2016-05-12 00:29:55 UTC
TESTING with
LO 5.2.0.0.alpha1+
OS Version: Mac OS X 10.10.5
Build: 2016-05-11_01:01:27

(In reply to Mark Appier from comment #0)
Yesterday, I upgraded LibreOffice to Verision: 4.4.1.2 Build ID:
> 45e2de17089c24a1fa810c8f975a7171ba4cd432 Locale: en_US being run on Windows
> Vista As I have done a large number of times with previous builds, I typed a
> short email to send to all of our school students, parents, and patrons. A
> list of all of the emails was extracted out of our SIS (School Information
> System) which I then pasted into Calc and saved as All_Emails.ods.

Substitute test spreadsheet TEST.ODS created with entries as follows:
A1 = foo@example.com
A2 = bar@example.com

> As
> normal, loaded the data sorce,

To summarize the steps:

Tools -> Mail Merge Wizard -> (Next) -> (Choose Email message) -> (Next)
(Select Address List) -> (Add) -> (TEST.ODS) -> (OK) -> (Next)

(Uncheck salutation option) -> (Finish)

> LO constructed the merged file (nothing to
> merge as I am sending the same message to everyone), selected the
> appropriate field from which to send the emails (the only one), and pressed
> the send button.

Clicked (Send E-Mail Messages) button,
got 'E-mail merged document' dialog, and clicked (Send Documents) button

Got a blank (no text present) pop-up Info box (icon like: https://openclipart.org/detail/37255/info-icon) with buttons: Yes, No, & Cancel.

[[ ==> Missing dialog text is perhaps a separate bug? ]]

Tried the 'Yes' button, and then corrected my SMTP settings.

Added a Subject for the message 'TEST EMAIL', and clicked (OK)

> then LO crashed (not the Mailmerge dialog box)
>

LibreOffice then became unresponsive. I don't repro a crash, but the problem appears to persist, so I'll consider this CONFIRMED on 5.2-master.
Comment 5 Caolán McNamara 2016-06-12 19:48:38 UTC
I believe the crash is the same problem as 89214. Has the same initial commit as the regression too.

*** This bug has been marked as a duplicate of bug 89214 ***