Bug 90224 - FILEOPEN: extreme delay with textboxes
Summary: FILEOPEN: extreme delay with textboxes
Status: RESOLVED DUPLICATE of bug 89165
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-03-25 10:14 UTC by László Németh
Modified: 2019-11-01 09:52 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
DOCX test document with a few textboxes (18.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-03-25 10:15 UTC, László Németh
Details
ODT conversion of the pervious DOCX file (9.69 KB, application/vnd.oasis.opendocument.text)
2015-03-25 10:20 UTC, László Németh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description László Németh 2015-03-25 10:14:39 UTC
Loading of the attached test documents with textboxes can result extreme loading delays (depending from hardware, too, eg. on a faster i7 machine with a 21" monitor, instead of the instant loading, waits 30 sec, too).
Comment 1 László Németh 2015-03-25 10:15:51 UTC
Created attachment 114332 [details]
DOCX test document with a few textboxes
Comment 2 László Németh 2015-03-25 10:20:11 UTC
Created attachment 114333 [details]
ODT conversion of the pervious DOCX file

The ODT format can result different (bigger or shorter) delays
Comment 3 László Németh 2015-03-25 10:25:54 UTC
# bad: [cf6ea17155fabb2a120ba07c150735591ac861d7] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [fc71ac001f16209654d15ef8c1c4018aa55769f5] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect start 'latest' 'oldest'
# bad: [8cf60cc706948588e2f33a6d98b7c55d454e362a] source-hash-f340f0454627939f1830826fb5cc53a90e6c62a4
git bisect bad 8cf60cc706948588e2f33a6d98b7c55d454e362a
# bad: [d9885f526fc7a09cc8f9f8ee643af1b966be24bb] source-hash-d1465c64c6f64ad8dd25e40cdc69649b24b305ea
git bisect bad d9885f526fc7a09cc8f9f8ee643af1b966be24bb
# good: [e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a] source-hash-dc9cc46f3223aff3f85d3ce9696178a5f4d3d087
git bisect good e3eab511ffbcd2e1e2c67e7a4fec162bb0b26b7a
# good: [1477f347fb61b5b07de64312247b49371812f5b4] source-hash-4598bbe41d0906a34ceb1126c7fce2108642cd8e
git bisect good 1477f347fb61b5b07de64312247b49371812f5b4
# good: [fdbfc593506d9f38152b80f14c9e7afdbef0b40a] source-hash-6024ddbfac8e62db50dd5352d610c87d279627de
git bisect good fdbfc593506d9f38152b80f14c9e7afdbef0b40a
# bad: [b1d1e3e3ac1515cf33be95eba837476142fb6ca8] source-hash-f55ddffd7e81cc8f3314047a6aa62991e2d293b1
git bisect bad b1d1e3e3ac1515cf33be95eba837476142fb6ca8
# good: [e5308eaa46281027dc932b4a6550e7b1f0ba0622] source-hash-822d0e9db610ce3cbee2cf8d3154ee41218ea562
git bisect good e5308eaa46281027dc932b4a6550e7b1f0ba0622
# bad: [3b2df848ba35308d33b712b69972c575245562fb] source-hash-c00d81612e128b74c23c95e011b482dc3918fca4
git bisect bad 3b2df848ba35308d33b712b69972c575245562fb
# good: [375cc64c4e47595d7e15067faa352357289af79d] source-hash-0751477a375e0b6bb82c5aa47c9e666d6dc2ba8c
git bisect good 375cc64c4e47595d7e15067faa352357289af79d
# good: [b553dc4f8b71e9f5c2208cb3464bb2ccadf11476] source-hash-c7d6541f5daa59d04accb30c727a83d936f02150
git bisect good b553dc4f8b71e9f5c2208cb3464bb2ccadf11476
# good: [c84133d326811380158ac362beb0475e02abbd8c] source-hash-af70a45633b34eaae4eb4577b763dadfc48c74b6
git bisect good c84133d326811380158ac362beb0475e02abbd8c
# good: [51a14bb82d6b3a5cc1dd77e403b61aca8616e84a] source-hash-e48a2339600d12d43148bbdb9a47770ae9bc94e3
git bisect good 51a14bb82d6b3a5cc1dd77e403b61aca8616e84a
# good: [257927c5684756fa0c95ebefd405ca328ffc4b6d] source-hash-4f33a0961d69feba72806d105da65a4dc841ca5e
git bisect good 257927c5684756fa0c95ebefd405ca328ffc4b6d
# first bad commit: [3b2df848ba35308d33b712b69972c575245562fb] source-hash-c00d81612e128b74c23c95e011b482dc3918fca4
Comment 4 László Németh 2015-03-25 11:18:37 UTC
Maybe useful warnings:

With https://wiki.documentfoundation.org/QA/HowToBibisect#latest_libreoffice-x-y_branchpoint_to_latest_master:

dcontact.cxx:1151: <SwDrawContact::_Changed(..)> -  unknown nested <UserCall> event. This is serious, please inform OD.

From another debug build (printed 250 times for a single loading):

objectformattertxtfrm.cxx:307 <SwObjectFormatterFrm::DoFormatObjs()> called for invalidate anchortext frame.
calcmove.cxx:1044: Format for locked TxtFrm.
Comment 5 Matthew Francis 2015-03-25 11:32:23 UTC
@László: With results from 44max, provided the bisect gave a single commit as the result, you can take it to be the exact source commit which introduced the issue and Cc the person in question directly.

(I don't see as extreme a slowdown as you experienced, but I do see a difference between ~instant and a few seconds, and the commit you landed on seems pertinent)
Comment 6 Matthew Francis 2015-03-25 11:32:43 UTC
Adding Cc: to vmiklos@collabora.co.uk; Could you possibly take a look at this? Thanks

    commit c00d81612e128b74c23c95e011b482dc3918fca4
    Author:     Miklos Vajna <vmiklos@collabora.co.uk>
    AuthorDate: Fri Jun 27 13:47:11 2014 +0200
    Commit:     Miklos Vajna <vmiklos@collabora.co.uk>
    CommitDate: Fri Jun 27 15:56:05 2014 +0200
    
        SwFlyFrm::Format: inform our custom shape about size changes if needed
Comment 7 Miklos Vajna 2015-10-09 22:42:24 UTC
Bug 89165 is bisected to this very same commit, both are about docx files / textboxes and performance problems -> mark as duplicate.

*** This bug has been marked as a duplicate of bug 89165 ***
Comment 8 Robinson Tryon (qubit) 2015-12-15 11:03:31 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]
Comment 9 Commit Notification 2019-11-01 09:52:41 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/202a49a5831fbfcf057350ef949c13e75b3b7446

crashtesting: out of bounds on importing tdf90224-2.odt

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.