Download it now!
Bug 90225 - Cannot open compressed csv files from calc
Summary: Cannot open compressed csv files from calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium enhancement
Assignee: Dennis Francis
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-25 12:13 UTC by Dennis Francis
Modified: 2015-04-27 20:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
sample gzip compressed csv file (1.60 KB, application/gzip)
2015-03-25 12:13 UTC, Dennis Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dennis Francis 2015-03-25 12:13:36 UTC
Created attachment 114334 [details]
sample gzip compressed csv file

It will be very useful if calc can directly open compressed csv files without the user having to manually extract the csv file from the compressed file first. 

Currently if I try to open the attached file "rand.csv.gz" from Calc, it shows the text import dialog but the preview shows garbage text.
Comment 1 raal 2015-03-25 18:19:46 UTC
I can open file from tar.gz file without problem (from archive manager)

Version: 4.5.0.0.alpha0+
Build ID: c3087d969671e62182eb049850479e77190ccff4
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-03-22_04:37:00

Garbled text I see when I open .gz file directly from calc. It's not common to edit zipped file directly, I don't support this idea. Leaving unconfirmed.
Comment 2 Dennis Francis 2015-03-25 18:35:09 UTC
(In reply to raal from comment #1)
> I can open file from tar.gz file without problem (from archive manager)
> 

Suppose you have lots of *.csv.gz files (which is in my case), and you want to see them in spreadsheet to do some analysis, it is preferable to be able to **open from Calc**. This is different compared to __invoking__ Calc with the extracted file. And it is not about opening an archive (tarball), I am trying to open a compressed file *.csv.gz (containing only one csv file) from Calc.
Comment 3 Buovjaga 2015-03-26 12:11:12 UTC
Asked for opinions in the dev channel and the consensus was that this is an OK enhancement request, so I'm setting to NEW.
Comment 4 Dennis Francis 2015-04-01 15:26:23 UTC
Submitted a patch at https://gerrit.libreoffice.org/#/c/15108/
Comment 5 Buovjaga 2015-04-05 09:14:35 UTC
*** Bug 90460 has been marked as a duplicate of this bug. ***
Comment 6 Commit Notification 2015-04-27 00:35:06 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f0edb677f09ad338e22ac3b5d91497b4479e0b3c

enhancement : tdf#90225 Cannot open compressed csv files from calc

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Kohei Yoshida 2015-04-27 20:50:30 UTC
I'll set this resolved.  There is a few very minor known issues which we may want to tackle at some point, but the core part should be working fine.