Download it now!
Bug 90245 - FILESAVE: Table Merge cell properties not preserved after saving file as .pptx
Summary: FILESAVE: Table Merge cell properties not preserved after saving file as .pptx
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Sujith
URL:
Whiteboard: target:5.0.0
Keywords: filter:pptx, implementationError
Depends on:
Blocks:
 
Reported: 2015-03-26 07:42 UTC by Sujith
Modified: 2015-12-10 10:32 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
.odp file with table merge cells (11.29 KB, application/vnd.oasis.opendocument.presentation)
2015-03-26 07:42 UTC, Sujith
Details
pptx with table merged cells (40.64 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2015-03-26 07:45 UTC, Sujith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sujith 2015-03-26 07:42:52 UTC
Created attachment 114366 [details]
.odp file with table merge cells

Steps to reproduce this issue:
1. Create a presentation file on latest master
2. Insert a table
3. Merge some of the table cells
4. Save file as .pptx file
5. Open saved file on LO again

OR 
1. Open .odp attached file on latest master and save it as .pptx file.

OR 
1. Open attached .pptx file on latest master and save it as .pptx again


Current behaviour:
1. If opened saved file on LO again, merged cells are not preserved

Expected behaviour:
1. Table merged cells should retain their property
Comment 1 Sujith 2015-03-26 07:45:13 UTC
Created attachment 114367 [details]
pptx with table merged cells
Comment 2 raal 2015-03-26 14:56:05 UTC
I can confirm with LO 4.4.1.2, win7
Comment 3 Matthew Francis 2015-03-28 08:35:02 UTC
This is reproducible back to at least 3.6.
Before 3.6, round tripping such a table through PPTX either results in the table being missing upon reload or crashing on reload. I can't find a version that does anything better than the current behaviour.

So not a regression - this has probably just never worked since LO introduced PPTX as a feature back in 3.3.0 (OOo / AOO has never supported it)
Comment 4 Sujith 2015-04-13 17:21:45 UTC
Raised the CL for supporting export of table merged cell:
https://gerrit.libreoffice.org/#/c/15282/
Comment 5 A (Andy) 2015-04-17 20:57:57 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 6 Commit Notification 2015-05-18 10:33:55 UTC
Sujith Sudhakaran committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e4fab06d82299054ddd46c7d925d300cd3d0a17d

tdf#90245: Support for table merge cell export.

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Robinson Tryon (qubit) 2015-12-10 10:26:08 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-12-10 10:31:50 UTC
Confirming that now merged cells are preserved.
I saved the odp as pptx.

Win 7 Pro 64-bit, Version: 5.0.3.2 (x64)
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: fi-FI (fi_FI)

Version: 5.2.0.0.alpha0+
Build ID: 81fa5340191baf8687f9c82f1f414f5afc86b529
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-12-03_21:19:19
Locale: fi-FI (fi_FI)