Bug 90298 - REGRESSION: LibO spell checker / dictionaries aren't used at all
Summary: REGRESSION: LibO spell checker / dictionaries aren't used at all
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All Mac OS X (All)
: high blocker
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.3
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-03-28 16:16 UTC by Frank Fuchs
Modified: 2015-06-08 14:36 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frank Fuchs 2015-03-28 16:16:21 UTC
In LibO 4.4.2.2 on Mac OSX, the LibO spell checker / dictionaries are not used at all (tested with Writer). Just Mac OSX's own spell checker / dictionary is being used. This is a regression from LibO 4.3.x.

Open an ODT file in Writer. Spell checking is based on the systems' (Mac OSX) inherent spell checking mechanism, only. The LibO ones are not used.
Please check:
open LibO Writer, then open LibO settings - language settings - linguistics. On the right hand side you see the list of available spell checkers (et al), including the ones installed with LibO. Double click on one (e.g. hunspell) to be able to see the detailled settings. In the detailled settings you will see that only the Mac's OSX spell checker is used. Grammar, thesaurus and hyphenation don't even show/list any available spell checking module.
An easy double check for this is (if you are using German language) that the Mac's spell checker does not differentiate between the German "ss" and the German "ß", while the LibO checkers used to to that.

Within the LibO 4.4.x LibO package on Mac, the dictionaries are now in a different location compared to LibO 4.3.x. Maybe because of that they are not 'found' anymore within LibO?

For me, this is a blocker because spell checking and hyphenation is unusable on Mac OSX.
Comment 1 Alex Thurgood 2015-03-30 17:26:17 UTC
Version: 4.5.0.0.alpha0+
Build ID: 09f83e1f409853a6c6e4300287c4e50bad5b9d0b
Locale: fr_

Confirming

OSX 10.10.2

On master build the dictionary dialogs additionally have black backgrounds making it impossible to tell which dictionaries are being used, this is a separate issue.
Comment 2 Alex Thurgood 2015-03-30 17:27:33 UTC
Andras : any idea what might have happened ?
Comment 3 Alex Thurgood 2015-03-30 17:31:13 UTC
(In reply to Alex Thurgood from comment #1)


> 
> On master build the dictionary dialogs additionally have black backgrounds
> making it impossible to tell which dictionaries are being used, this is a
> separate issue.

The UI bug is indeed already known, and bibisected
Comment 4 Alex Thurgood 2015-03-30 17:32:12 UTC
cloph : any idea ?
Comment 5 Alex Thurgood 2015-03-31 13:37:55 UTC
My mistake on master build, I didn't have the hunspell dictionaries built, so naturally I couldn't see them when I tried to edit the list (but the black background bug didn't help matters here).

Not confirming on my master build.

I can also not confirm on LO 4412 production release, as the Hunspell dictionary shows up, and clicking on Edit lists the Hunspell spellchecker as well as OSX spellchecker.
Comment 6 Alex Thurgood 2015-03-31 13:55:25 UTC
Cloph informs me that the dict-xx uno package is not registered with the app
Comment 7 Alex Thurgood 2015-03-31 13:55:50 UTC
So, the bug is still confirmed
Comment 8 Alex Thurgood 2015-03-31 14:22:11 UTC
Confirming on 

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fr_

with IT langpack

The IT langpack doesn't show any hunspell dictionary as being installed, only the OSX dictionary
Comment 9 Alex Thurgood 2015-03-31 14:22:35 UTC
A workaround seems to be to delete the user profile and re-install the langpack, but this is represents an unplanned configuration change between point releases, so probably not acceptable (if I have understood the principle correctly)
Comment 10 Alex Thurgood 2015-03-31 14:23:39 UTC
Worthy of blocker status methinks ?
Comment 11 Christian Lohmaier 2015-03-31 14:40:27 UTC
no path problem, but problem with registering the extensions with LibreOffice - they don't get picked up.

Reason for that is that LibreOffice compares the timestamp of the shared extension folder with a file in the user's profile.

Due to the way the languagepacks work on Mac, this doesn't work, as the folder is set to the build-time of the languagepack, not to the time of the current installation.

Workaround is to either remove the file from the user's profile:

"rm ~/Library/Application\ Support/LibreOffice/4/user/extensions/bundled/lastsynchronized"

(should be one line)

or to touch (= update the timestamp) of the shared/bundled extensions folder:

"touch <installdir>/LibreOffice.app/Contents/Resources/extensions"

The latter will be added to the languagepack installer (but might be less accessible for the user, since when installing to /Applications this likely requires running with sudo to have admin privileges)
Comment 12 Commit Notification 2015-03-31 15:09:39 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b89681bef2e492bccb9502079e042ff495b40c39

tdf#90298 rescan for bundled extensions when installing Mac langpack

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Robinson Tryon (qubit) 2015-03-31 16:40:57 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so
called MAB (most annoying bugs). As this bug has not run
through that process (including writing a short rationale for
this bug being a candidate and other who are watching the
tracker bug silently approving that rationale etc), its priority
is set to high. Note this is effectively no change in the
urgency assigned to this bug, as we are currently not making a
difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by
contacting the QA Team on IRC:

http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact
with the team (if IRC fails you, your next best choice is the
mailing list):

https://wiki.documentfoundation.org/QA
Comment 14 Commit Notification 2015-03-31 18:08:25 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c8bf06bc5d5d8621c86b5f7a8a0cdda1cacb03b3&h=libreoffice-4-4

tdf#90298 rescan for bundled extensions when installing Mac langpack

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Michael Meeks 2015-06-08 14:36:19 UTC
Fixed long ago, but not closed - closing; can you verify fixed ? =)