Bug Hunting Session
Bug 90301 - UI: CRASH Assertion failed in file include/rtl/ustring.hxx after pressing back button the Function Wizard
Summary: UI: CRASH Assertion failed in file include/rtl/ustring.hxx after pressing bac...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Eike Rathke
URL:
Whiteboard: target:4.5.0 target:4.4.3 target:4.3.7
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-03-28 18:56 UTC by Łukasz Hryniuk
Modified: 2015-03-31 08:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace from gdb (17.28 KB, text/plain)
2015-03-28 18:56 UTC, Łukasz Hryniuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Łukasz Hryniuk 2015-03-28 18:56:57 UTC
Created attachment 114423 [details]
Backtrace from gdb

1. create new spreadsheet
2. click on a cell
3. click on the Function Wizard button
4. choose a "Statistical" category (should work for all of them)
5. choose FTEST function (should also work for other functions)
6. press the "Next >>" button
7. click on Function Wizard button (beside data_1 string, in the Function Wizard window)
8. press the "<< Back" button
9. assertion failed error and a crash
Comment 1 Julien Nabet 2015-03-29 00:05:03 UTC
On pc Debian x86-64 with master sources updated yesterday, I could reproduce this.
(I don't use RTL UI, so not specific to RTL)

Lukasz: on which LO version are you?
Comment 2 Julien Nabet 2015-03-29 00:07:00 UTC
Submitted a patch to review here:
https://gerrit.libreoffice.org/15046
Comment 3 A (Andy) 2015-03-29 06:28:46 UTC
For me not reproducible with LO 4.4.1.2., Win 8.1
Comment 4 Łukasz Hryniuk 2015-03-29 09:19:48 UTC
(In reply to Julien Nabet from comment #1)
> Lukasz: on which LO version are you?

Sources from master branch.
Comment 5 Julien Nabet 2015-03-30 18:13:02 UTC
My patch was wrong and have no idea how to fix this correctly.
So I put it back to NEW.
Comment 6 Eike Rathke 2015-03-30 18:46:44 UTC
Taking.
Comment 7 Commit Notification 2015-03-30 19:35:23 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eed393039a9067f7a1a318934ff1c5ff90bfe443

Resolves: tdf#90301 string access out of bounds

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2015-03-30 19:51:12 UTC
Note that the "crash" is due to an assertion that is not effective in non-dbgutil builds.
Comment 9 Eike Rathke 2015-03-30 20:03:48 UTC
Pending review
https://gerrit.libreoffice.org/15074 for 4-4
https://gerrit.libreoffice.org/15075 for 4-3
Comment 10 Commit Notification 2015-03-31 08:29:14 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d63406ec35ce3d22b8f3e78b46c46dd71b6b91e4&h=libreoffice-4-4

Resolves: tdf#90301 string access out of bounds

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-03-31 08:30:26 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c398d1b669551352d8916e792447ec6e495e9c1&h=libreoffice-4-3

Resolves: tdf#90301 string access out of bounds

It will be available in 4.3.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.