Download it now!
Bug 90330 - Corruption of saved file when comment is deleted with track changes
Summary: Corruption of saved file when comment is deleted with track changes
Status: RESOLVED DUPLICATE of bug 89615
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2015-03-29 18:28 UTC by Matt Copperwaite
Modified: 2017-04-14 08:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Copperwaite 2015-03-29 18:28:01 UTC
I'm working on a pretty large file, authoring for PacktPub, and I'm running in to a pretty consistent issue.

The file is converted from a DOCX file, it has track changes turned on. It also has a lot of comments. The file will work fine. However if I delete a comment, save the file and re-open it. I get the error:

    Read-Error.
    Format error discovered in the file in sub-document content.xml at 2,6039(row,col).

If I extract the content.xml and run xmllint on it I get the error:

    content.xml:2: parser error : Attribute office:name redefined
    ame="__Annotation__2034_67113285111111" style:name="Table1" style:family="table"

The first matching elements I find does indeed have 2 `office:name` element attributes:

    <style:style office:name="__Annotation__1877_671132851111111111111" office:name="__Annotation__2034_67113285111111" style:name="Table1" style:family="table">
        <style:table-properties style:width="13.97cm" table:align="margins" style:writing-mode="lr-tb"/>
    </style:style>

Both `office:name` attribute values do refer to valid annotations. My solution to fixing the file is to remove that element, but if I delete another comment the problem arises again.
Comment 1 Buovjaga 2015-04-04 15:21:18 UTC
Could you provide a sanitized version of the file, perhaps with only a single page that shows the problem?
https://wiki.documentfoundation.org/Anonymizing_a_document#Sanitize_file_text

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document.
Comment 2 Matt Copperwaite 2015-04-05 16:40:07 UTC
I followed the instructions but could no-longer replicate this issue but I am now on version 4.3.6.2.

Will keep an eye on it to see if it resurfaces.
Comment 3 raal 2015-04-13 19:05:41 UTC
(In reply to Matt Copperwaite from comment #2)
> I followed the instructions but could no-longer replicate this issue but I
> am now on version 4.3.6.2.
> 
> Will keep an eye on it to see if it resurfaces.

Closing for now. Set again to unconfirmed if problem occurs.
Comment 4 Michael Stahl (CIB) 2016-07-11 21:02:33 UTC

*** This bug has been marked as a duplicate of bug 89615 ***