Bug 90334 - SECTION COLUMNS: unrelated texts placed in columns shouldn't have to interact
Summary: SECTION COLUMNS: unrelated texts placed in columns shouldn't have to interact
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium enhancement
Assignee: sdc.blanco
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-03-29 22:07 UTC by Matthew Millar
Modified: 2020-11-09 03:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Millar 2015-03-29 22:07:54 UTC
The text-flow of multiple columns should include manual formatting, where text can be placed in either column as the users discretion. This would imply that neither automatic overflow or even-distributation occurs between the columns.

Currently text in column n-1 always directly effects the layout or presence of text in column n, either text is evenly distributed between the columns or once the former column is full content then overflows into the second column.

However, this is not appropriate for conflicting or non-progressive texts.

E.g.
Software management is segmented into two elements: administration and deployment
Administration | Deployment
blerb about    | blerb about 
administration.| deployment.
Though the     |
column on      |
administration | 
goes on for a  |
little bit     |
longer, it     |
doesn't reach  |
the bottom of  |
the page.      |
Comment 1 Buovjaga 2015-04-06 11:09:18 UTC
Would this work for you: Insert - Manual break - Column break?

Set to NEEDINFO.
Change back to UNCONFIRMED, if Column break is not enough for you. Change to RESOLVED INVALID, if you determine it does what you need.
Comment 2 Matthew Millar 2015-04-12 16:20:55 UTC
Your solution works.

I've redesignated this bug as Documentation because I attempted to research a solution prior to filing a bug but was unable to find this information in the writer guide.

ISSUE:
Unable to find information about non-table column breaks in Writer documentation.

Writer 4.2 Guide:
Searching "manual break" doesn't return any information about column breaks.
Searching "column break" only isolates text-flow formatting in table text (and the shortcut key).

SOLUTION:
The Writer Guide needs to include a column break explanation on 130, as a definition for "Manual" in the section "distributing text across columns".
Comment 3 Robinson Tryon (qubit) 2015-04-17 20:00:18 UTC
(In reply to Matthew Millar from comment #2)
> Your solution works.
> 
> I've redesignated this bug as Documentation because I attempted to research
> a solution prior to filing a bug but was unable to find this information in
> the writer guide.

Better docs sounds like a good plan.
Status -> NEW
Comment 4 Commit Notification 2020-11-09 01:48:22 UTC
Seth Chaiklin committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/db325f95386ada37f4e4de2bc806f27639dda7f8

tdf#90334 add bookmarks to insert column break in Writer
Comment 5 sdc.blanco 2020-11-09 01:58:11 UTC
Is Bugzilla also used for Writer's Guide? If so, then the problem identified here (about inadequate explanation of manual column break) is still lacking in Writer's Guide 6.4.

If Bugzilla is not used for Writer's Guide, then maybe this bug should be closed as FIXED or WFM.  There is online documentation about manual column break.  And the patch in comment 4 adds bookmarks using the search terms mentioned in comment 2 (plus a couple more).
Comment 6 Adolfo Jayme 2020-11-09 03:37:35 UTC
Any issue in the guides should be reported on the documentation mailing list.