Download it now!
Bug 90378 - Header and footer background bitmap images are not saved
Summary: Header and footer background bitmap images are not saved
Status: RESOLVED DUPLICATE of bug 89245
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-03-31 17:45 UTC by max+freedesktop
Modified: 2015-04-04 14:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description max+freedesktop 2015-03-31 17:45:12 UTC
I had an odf file, which was created with LibreOffice Writer 4.2, that used a png image for the header background. The image was still there when opened with LibreOffice 4.4.1.2. However, after saving and re-opening the file, the image is gone. I also noticed that the file size is about half the original and can no longer be opened with 7-Zip as an archive, so I'm guessing that there were some significant changes to the save code in 4.3 or 4.4 that introduced this bug.

To reproduce:

1. Create a new document with Writer 4.4.1.2
2. Insert -> Header -> Default Style
3. Header -> Format Header... -> More...
4. Area -> Fill with 'Bitmap'
5. Import Graphic... -> Select some png file
6. Uncheck 'Tile' and 'AutoFit'
7. OK -> OK
8. Save as a new file and close Writer
9. Open the saved file, the image is no longer there

Only tested on Windows 8.1, but I'm guessing that it would affect all other OSes as well.
Comment 1 A (Andy) 2015-03-31 21:17:20 UTC
Reproducible with LO 4.4.1.2, Win 8.1

Note to Step 3:
PAGE -> tab FORMAT HEADER -> MORE...
Comment 2 Matthew Francis 2015-04-04 14:57:44 UTC

*** This bug has been marked as a duplicate of bug 89245 ***