Bug Hunting Session
Bug 90393 - Text cell as first cell in range should not automatically be considered as label
Summary: Text cell as first cell in range should not automatically be considered as label
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-UX Sorting
  Show dependency treegraph
 
Reported: 2015-04-01 13:11 UTC by Regina Henschel
Modified: 2018-11-22 14:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2015-04-01 13:11:02 UTC
This issue is about the one-click sort options in the toolbar, which are commands .uno:SortAscending and .uno:SortDescending.

If you select a vertical range of cells and use these commands, you can observe the following behavior:
(1) If the first cell is numeric, LibreOffice sorts the whole range.
(2) If the first cell is a text cell, LibreOffice assumes first cell is a label and sort starts with the second cell of the range.

In case of (2) there is no way to tell LibreOffice to _not_ use the first cell as label. [I know you can sort it as desired by using the long way over Data > Sort etc., which is command .uno:DataSort, but this issue is about the above mentioned special sort icons.]

The missing ability to allow the user to decide whether the first cell is a label or not creates confusion, read e.g thread http://nabble.documentfoundation.org/LibreOffice-Sort-Bug-td4144500.html

In addition, Excel does not assume a label, if all cells are text cells. Therefore the behavior in LibreOffice is unexpected for persons switching from Excel.
Softmaker works as Excel, Gnumeric has no one-click sort, but only a dialog.

You can think of a global setting, a per document setting, a popup asking, different commands for assuming label or not, or other ideas. There is no obvious solution and therefore I think, it should be discussed in UX.
Comment 1 V Stuart Foote 2015-04-01 13:35:10 UTC
New and into the ux-advise pool...
Comment 2 V Stuart Foote 2015-04-01 13:54:08 UTC
Further to Regina's OP, which concisely states the UI/UX issue of no way to control default behavior, considerable gyrations on the User ML before spinning off the enhancement request.

=-refs-=
http://nabble.documentfoundation.org/LibreOffice-Sort-Bug-tc4144500.html
http://nabble.documentfoundation.org/FEATURE-REQUEST-for-the-Sort-options-in-Calc-tc4144509.html
Comment 3 Tim Deaton 2015-04-01 17:31:51 UTC
(As I commented in the Nabble thread)

If you do the sort using the menu (Data > Sort), the box that opens up contains two tabs (Sort Criteria, & Options). The default is to treat the top cell as a LABEL, (if that cell is text, at least), but nothing is visible to tell you that.  If you do NOT HAVE any column labels, you have to go to the OPTIONS tab (every time) and UN-SELECT the "Range Contains Column Labels" box.

That "Range Contains Column Labels" checkbox SHOULD be on the SORT CRITERIA tab, so that the user sees it every time he performs the sort operation.  Likewise, using one of the SORT icons should also open up that same box.  The only difference should be that the default sort order changes depending on which icon is hit.

LO Version: 4.3.5.2
Windows 7 64-bit

-- Tim
Comment 4 Robinson Tryon (qubit) 2016-08-25 05:26:53 UTC Comment hidden (obsolete)
Comment 5 Heiko Tietze 2017-10-23 15:34:41 UTC
To recapitulate for the ML, this ticket is about toolbar functions to sort where the first row is taken as header in case it's not numeric. 

Simple solution is to just pop-up a confirmation box "Use the first row as column labels" (yes/no) in case of non-numeric cells on top. 

But in my opinion we should keep the current situation as there is the dialog interaction with the (cumbersome) second tab to uncheck "Range contains column labels".

Opinions?
Comment 6 Heiko Tietze 2018-07-02 08:46:44 UTC
*** Bug 118471 has been marked as a duplicate of this bug. ***
Comment 7 Heiko Tietze 2018-07-02 08:48:37 UTC
(In reply to Heiko Tietze from comment #6)
> *** Bug 118471 has been marked as a duplicate of this bug. ***

From the other thread

(In reply to Drew Jensen from comment #2)
> (In reply to Julien Nabet from comment #1)
> > Heiko/Xisco: should "Range contains column labels" be checked by default so
> > the by default sort would consider first line as a label?
> 
> If by default (which it is in the sort dialog on my installation) that is
> good.
> 
> But that does not appear to influence the behavior of the Ascending and
> Descending sort tool bar buttons actions. (when the sort dialog is not
> invoked). When those are used the option in the sort dialog has no effect.
> 
> I would say the current behavior is a bug and for sort functions not
> triggered from the dialog box the behavior should be to defaulted to 'first
> row contains labels' when the user has selected a full column and should not
> have that option set when the user manually selects a range of cells. 
> 
> I would not use the setting from the sort dialog, as it becomes a hidden
> setting to most users.

The issue with sorting was not confirmed there but the request to ignore is relevant here.
Comment 8 Heiko Tietze 2018-11-22 14:19:21 UTC
No further input on this topic, let's close as WFM. Actually I prefer the LibreOffice way over MS.