Bug 90397 - file does't open correctly
Summary: file does't open correctly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2015-04-01 14:40 UTC by fabriadri
Modified: 2020-06-21 23:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
doc document with table error (130.50 KB, application/msword)
2015-04-01 14:40 UTC, fabriadri
Details
docm of doc with corrections of mso 2016 (85.68 KB, application/vnd.ms-word.document.macroEnabled.12)
2020-03-27 12:10 UTC, paulystefan
Details
doc without password (130.50 KB, application/msword)
2020-03-28 10:01 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fabriadri 2015-04-01 14:40:56 UTC
Created attachment 114527 [details]
doc document with table error
Comment 1 A (Andy) 2015-04-02 21:03:02 UTC
Reproducible with LO 4.4.1.2, Win 8.1

all the text seems to be in one narrow column
Comment 2 Matthew Francis 2015-04-04 11:40:45 UTC
Same result on Linux / LO 3.3.0

-> Platform: All
-> Version: Inherited from OOo
Comment 3 tommy27 2016-04-16 07:25:48 UTC Comment hidden (obsolete)
Comment 4 fabriadri 2016-04-30 16:26:03 UTC
The bug still exists. Libreoffice 5.1.2 Windows 10
Comment 5 Telesto 2017-04-24 20:03:23 UTC
Confirming with:
Version: 5.4.0.0.alpha0+
Build ID: 4354f0e9ef4a5538729a2a6f2d1745e247f6c5cd
CPU threads: 4; OS: Windows 6.19; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-04-21_06:05:57
Locale: nl-NL (nl_NL); Calc: CL
Comment 6 QA Administrators 2018-04-25 02:33:00 UTC Comment hidden (obsolete)
Comment 7 paulystefan 2020-03-27 12:10:53 UTC
Created attachment 159064 [details]
docm of doc with corrections of mso 2016

bug in LO 6.4.2.2 x64 win 10-64 also


workaround

save in MSO 2016 as docm

and than open in LO 

and writing as odt is successful.

perhaps a way in LO

only reading correct old or newer MSO files with corrections of MS

invention of wheel is here done by Microsoft
Comment 8 Timur 2020-03-28 10:01:58 UTC
Created attachment 159090 [details]
doc without password

Original issue with single column is resolved, at least in LO 6.4. So I mark as WFM.

Document looks pretty good now, except (better seen in .DOC without password that I attach):
-added empty table on 1st page after Totale Veicolo and before PNEUMATICI INCLUSI NEL CANONE:

Note: fonts replaced, as Univers is used and not available in LO, so replaced with Arial, inherited from OO - good replacement. 
 
I don't understand the previous comment.
Comment 9 paulystefan 2020-06-21 23:20:11 UTC
in LO 7.0.0.0beta2 x64 win10 

table errors are solved, but

volvo car financial graphic is bad
some more small things top and down of the doc are not solved

comment 8
this doc is a doc with macros, so saving in mso2016 docm or docx are available.
docm is a ms office format for docs with makro.