Bug 90429 - ooo2gd crashes LibreOffice immediately
Summary: ooo2gd crashes LibreOffice immediately
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.4.0 target:6.3.3
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2015-04-03 10:01 UTC by paulkubed
Modified: 2020-05-03 14:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Apple crashtrace (96.16 KB, text/plain)
2015-04-03 13:57 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paulkubed 2015-04-03 10:01:20 UTC
Upon selection of either open/save LibreOffice quits immediately. OSX Yosemite.
Comment 1 paulkubed 2015-04-03 10:06:33 UTC
Although ooo2gd is an extension, the program should be handling the potential problem (not crashing), thus my rationale for submitting it under the main program rather than 'extensions.'
Comment 2 Alex Thurgood 2015-04-03 13:36:42 UTC
Until it has been confirmed I ahve reset this to medium normal.
ooo2gd is an extension installed optionally by the user (i.e. it is not bundled with LibreOffice). I doubt that this can ever be considered to be of high critical status.

It might also possibly be a regression, if it can be shown not to have crashed previous versions.

As to whether this is the extension's fault or the app's fault, this still remains to be determined. The default in most cases is to blame the extension, which after all, is an add on to existing functionality. It is not up to LibreOffice to remain compatible with non-bundled extensions, this is squarely up to the developers of the extension.

Changing component to extension.
Comment 3 Alex Thurgood 2015-04-03 13:40:11 UTC
I would add that the extensions site states that this extension has not been updated since 2011, and that it is only deemed compatible with 3.x versions of LibreOffice.
Comment 4 Alex Thurgood 2015-04-03 13:56:28 UTC
Confirming with

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fr_

and

ooo2gd 3.0.0 downloaded from the extensions website

Apple crash trace attached
Comment 5 Alex Thurgood 2015-04-03 13:57:04 UTC
Created attachment 114584 [details]
Apple crashtrace
Comment 6 Matthew Francis 2015-04-04 08:47:36 UTC
I can't see that this extension particularly works on 3.3.0.4 (although perhaps I just didn't figure out how to configure it properly), but on the other hand it doesn't crash either, so let's call this a regression

-> Keywords: regression
Comment 7 Stephan Bergmann 2015-06-17 06:22:20 UTC
(In reply to Alex Thurgood from comment #4)
> ooo2gd 3.0.0 downloaded from the extensions website

<http://extensions.libreoffice.org/extension-center/openoffice.org2googledocs-export-import-to-google-docs-zoho-webdav/releases/3.0.0/ooo2gd_3.0.0.oxt>
Comment 8 Stephan Bergmann 2015-06-17 06:55:38 UTC
(In reply to paulkubed from comment #0)
> Upon selection of either open/save LibreOffice quits immediately. OSX
> Yosemite.

I assume with "open/save" you mean entries like "Export to Google Docs" and "Import from Google Docs" in the extension's toolbar, not the stock "File - Open..." or "File - Save" menu entries.
Comment 9 Stephan Bergmann 2015-06-17 13:03:15 UTC
What I see on stderr is

> 2015-06-17 11:34:25.715 soffice[65431:120838] JavaNativeFoundation: GetGlobalVM: JNI_GetCreatedJavaVMs() failed to get any VM.
> 2015-06-17 11:34:25.720 soffice[65431:120838] Apple AWT Internal Exception: Unable to obtain JNIEnv for context: 0x0
> 2015-06-17 11:34:25.720 soffice[65431:120838] *** Terminating app due to uncaught exception 'Unable to obtain JNIEnv', reason: 'Unable to obtain JNIEnv for context: 0x0'

when the extension is trying to display an "Import from Google Docs" dialog via Java AWT/Swing.

A Java-on-Mac-OS-X-specific issue similar to <https://bz.apache.org/ooo/show_bug.cgi?id=92926> "Java AWT doesn't work (can't start)" perhaps, but hard to debug without the source code of the extension.
Comment 10 David Tardon 2015-06-19 07:58:04 UTC
@sberg: The source code of ooo2gd is at https://code.google.com/p/ooo2gd/source/list. If you want to do your own build, it might be easier to use ooo2gd package from Fedora (I hope it still builds--it was retired some time ago).
Comment 11 Robinson Tryon (qubit) 2015-12-10 01:26:22 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2017-01-03 19:42:07 UTC Comment hidden (obsolete)
Comment 13 Julien Nabet 2019-08-15 11:25:50 UTC
On pc Debian x86-64 with master sources updated today, I got an assert when trying to install:
#3  0x00007ffff7b0f102 in __GI___assert_fail
    (assertion=0x7fffe73cd37d "false", file=0x7fffe73cd078 "/home/julien/lo/libreoffice/configmgr/source/access.cxx", line=1902, function=0x7fffe73d8200 <configmgr::Access::initBroadcasterAndChanges(configmgr::Modifications::Node const&, configmgr::Broadcaster*, std::__debug::vector<com::sun::star::util::ElementChange, std::allocator<com::sun::star::util::ElementChange> >*)::__PRETTY_FUNCTION__> "void configmgr::Access::initBroadcasterAndChanges(const configmgr::Modifications::Node&, configmgr::Broadcaster*, std::__debug::vector<com::sun::star::util::ElementChange>*)") at assert.c:101
#4  0x00007fffe7305126 in configmgr::Access::initBroadcasterAndChanges(configmgr::Modifications::Node const&, configmgr::Broadcaster*, std::__debug::vector<com::sun::star::util::ElementChange, std::allocator<com::sun::star::util::ElementChange> >*) (this=0x555557752b10, modifications=..., broadcaster=0x7fff2510b810, allChanges=0x0) at /home/julien/lo/libreoffice/configmgr/source/access.cxx:1902
#5  0x00007fffe7382217 in configmgr::RootAccess::initBroadcaster(configmgr::Modifications::Node const&, configmgr::Broadcaster*) (this=0x555557752b10, modifications=..., broadcaster=0x7fff2510b810)
    at /home/julien/lo/libreoffice/configmgr/source/rootaccess.cxx:76
#6  0x00007fffe734ca3b in configmgr::Components::initGlobalBroadcaster(configmgr::Modifications const&, rtl::Reference<configmgr::RootAccess> const&, configmgr::Broadcaster*)
    (this=0x7fffe74730a0 <configmgr::Components::getSingleton(com::sun::star::uno::Reference<com::sun::star::uno::XComponentContext> const&)::singleton>, modifications=..., exclude=empty rtl::Reference, broadcaster=0x7fff2510b810) at /home/julien/lo/libreoffice/configmgr/source/components.cxx:261
#7  0x00007fffe7388e6b in configmgr::update::(anonymous namespace)::Service::insertExtensionXcuFile(sal_Bool, rtl::OUString const&)
    (this=0x55555b65d2a0, shared=0 '\000', fileUri="file:///home/julien/lo/libreoffice/instdir/program/../program/../user/uno_packages/cache/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/lucky2lo.tmp/Addons.xcu") at /home/julien/lo/libreoffice/configmgr/source/update.cxx:104
#8  0x00007fffe1f3944d in dp_registry::backend::configuration::(anonymous namespace)::BackendImpl::PackageImpl::processPackage_(osl::ResettableMutexGuard&, bool, bool, rtl::Reference<dp_misc::AbortChannel> const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) (this=0x55555c95aba0, doRegisterPackage=true, startup=false, xCmdEnv=empty uno::Reference)
    at /home/julien/lo/libreoffice/desktop/source/deployment/registry/configuration/dp_configuration.cxx:721
#9  0x00007fffe1f4322f in dp_registry::backend::Package::processPackage_impl(bool, bool, com::sun::star::uno::Reference<com::sun::star::task::XAbortChannel> const&, com::sun::star::uno::Reference<com::sun::star::ucb::XCommandEnvironment> const&) (this=0x55555c95aba0, doRegisterPackage=true, startup=false, xAbortChannel=uno::Reference to (class dp_misc::AbortChannel *) 0x55555c963888, xCmdEnv=empty uno::Reference)
    at /home/julien/lo/libreoffice/desktop/source/deployment/registry/dp_backend.cxx:635

If I disable the assert, I can install the extension.

I could click on any of the 5 icons, no crash, I got a Java style dialog.

I noticed these logs on console:
warn:configmgr:317:317:configmgr/source/xcuparser.cxx:159: bad set node <prop> member in "file:///home/julien/lo/libreoffice/instdir/program/../program/../user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/lucle3c1.tmp/Addons.xcu"
warn:configmgr:317:317:configmgr/source/xcuparser.cxx:159: bad set node <prop> member in "file:///home/julien/lo/libreoffice/instdir/program/../program/../user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/lucle3c1.tmp/Addons.xcu"

Any update?
Comment 14 Stephan Bergmann 2019-08-15 11:33:24 UTC
(In reply to Julien Nabet from comment #13)
> On pc Debian x86-64 with master sources updated today, I got an assert when
> trying to install:

Please give a link to the exact extension version you tried to install.
Comment 15 Julien Nabet 2019-08-15 11:44:12 UTC
(In reply to Stephan Bergmann from comment #14)
> ...
> Please give a link to the exact extension version you tried to install.

https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/ooo2gd/ooo2gd_3.0.0.oxt
Comment 16 Commit Notification 2019-08-16 06:17:38 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5a522a0196aaa071bd3ac59b3088246e3fe98f34%5E%21

Related tdf#90429: Don't erroneously pop unrelated path segments

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 17 Stephan Bergmann 2019-08-16 06:27:23 UTC
(In reply to Julien Nabet from comment #13)
> On pc Debian x86-64 with master sources updated today, I got an assert when
> trying to install:

that should be fixed with the commit from comment 16
Comment 18 Julien Nabet 2019-08-16 08:13:32 UTC
(In reply to Stephan Bergmann from comment #17)
> (In reply to Julien Nabet from comment #13)
> > On pc Debian x86-64 with master sources updated today, I got an assert when
> > trying to install:
> 
> that should be fixed with the commit from comment 16

Indeed, I don't reproduce the assertion with master sources updated today.
Thank you! :-)

There are still these logs on console:
warn:io.connector:20223:20286:io/source/connector/connector.cxx:93: Connector : couldn't connect to pipe 8a2dc8e6e63bcca36ccb11abe577cf116b43ca92c231dfdaf54461efb35679(10)

> accepting pipe,name=8a2dc8e6e63bcca36ccb11abe577cf116b43ca92c231dfdaf54461efb35679...connection established.warn:configmgr:20223:20286:configmgr/source/xcuparser.cxx:159: bad set node <prop> member in "file:///home/julien/lo/libreoffice/instdir/program/../program/../user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/ludtzanc.tmp/Addons.xcu"
warn:configmgr:20223:20286:configmgr/source/xcuparser.cxx:159: bad set node <prop> member in "file:///home/julien/lo/libreoffice/instdir/program/../program/../user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/ludtzanc.tmp/Addons.xcu"

but I suppose we could expect this since there are wrong paths in the oxt (if I well understood the comment of your commit)
Comment 19 Stephan Bergmann 2019-08-16 08:17:14 UTC
(In reply to Julien Nabet from comment #18)
> > accepting pipe,name=8a2dc8e6e63bcca36ccb11abe577cf116b43ca92c231dfdaf54461efb35679...connection established.warn:configmgr:20223:20286:configmgr/source/xcuparser.cxx:159: bad set node <prop> member in "file:///home/julien/lo/libreoffice/instdir/program/../program/../user/extensions/shared/registry/com.sun.star.comp.deployment.configuration.PackageRegistryBackend/ludtzanc.tmp/Addons.xcu"
> warn:configmgr:20223:20286:configmgr/source/xcuparser.cxx:159: bad set node
> <prop> member in
> "file:///home/julien/lo/libreoffice/instdir/program/../program/../user/
> extensions/shared/registry/com.sun.star.comp.deployment.configuration.
> PackageRegistryBackend/ludtzanc.tmp/Addons.xcu"
> 
> but I suppose we could expect this since there are wrong paths in the oxt
> (if I well understood the comment of your commit)

Yes, ooo2gd_3.0.0.oxt from comment 15 contains an Addons.xcu with bad content.
Comment 20 Commit Notification 2019-09-23 10:18:17 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-6-3":

https://git.libreoffice.org/core/commit/4c690773521517da8d9512ef1390284b59afd593

Related tdf#90429: Don't erroneously pop unrelated path segments

It will be available in 6.3.3.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Julien Nabet 2019-09-23 12:23:13 UTC
Let's put this one to FIXED since the patch has been backported in 6.3 branch
Comment 22 Stephan Bergmann 2019-09-23 13:02:41 UTC
(In reply to Julien Nabet from comment #21)
> Let's put this one to FIXED since the patch has been backported in 6.3 branch

While my "Related tdf#90429: Don't erroneously pop unrelated path segments" fix (comment 16, comment 20) fixes the issue from comment 13, I assume it does not fix the original issue from comment 0?
Comment 23 Julien Nabet 2019-09-23 13:16:11 UTC
(In reply to Stephan Bergmann from comment #22)
> (In reply to Julien Nabet from comment #21)
> > Let's put this one to FIXED since the patch has been backported in 6.3 branch
> 
> While my "Related tdf#90429: Don't erroneously pop unrelated path segments"
> fix (comment 16, comment 20) fixes the issue from comment 13, I assume it
> does not fix the original issue from comment 0?

Let's revert status then.
Comment 24 eisa01 2020-05-03 14:34:02 UTC
This no longer installs, I get the error:

Connector : couldn't connect to pipe 31c4238691d8e475aa2d778de61c37a118bff5f835249e55aa68a38e32d5b2(10)

The extension is unmaintained and there are reports of it not installing on the original github too, so I'm going to close this as not our bug as the issue in comment #0 is no longer applicable