Bug 90438 - FILESAVE: DOC shows errors/repairs when open with MS Office 2013
Summary: FILESAVE: DOC shows errors/repairs when open with MS Office 2013
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Not Assigned
Depends on:
Reported: 2015-04-03 17:24 UTC by Timur
Modified: 2020-10-13 08:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:

printscreen 5.0+ (13.96 KB, image/png)
2015-04-15 17:13 UTC, raal
printscreen 7.1+ (22.08 KB, image/png)
2020-10-13 08:15 UTC, Timur

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2015-04-03 17:24:35 UTC
While testing attachment 105190 [details] from bug 83005, I noticed that saving that ODT as DOC with LO and higher (including produces error when DOC is opened with Microsoft Office 2010 (2013 not tested).
Error says: File corrupt and cannot be opened. Worked up to LO
Opening that file gives different number of pages with different LO, which is another issue.
Comment 1 Timur 2015-04-03 17:26:56 UTC Comment hidden (obsolete)
Comment 2 Timur 2015-04-03 17:40:57 UTC Comment hidden (obsolete)
Comment 3 Timur 2015-04-10 08:25:07 UTC
Office 2013 can open the file with the message: Errors were detected in the file, but Word was able to open the file by making the repairs listed below.
Comment 4 Matthew Francis 2015-04-13 05:58:00 UTC
I can't reproduce this with LO and Mac Office 2011

One change in the number of pages was caused by the below - a fix rather than a regression, the behaviour after seems better

commit 7146d8bcd96f844dc0239a5b29a6b36c3cb5a2cc
Author: Miklos Vajna <vmiklos@collabora.co.uk>
Date:   Mon Jul 28 16:58:38 2014 +0200

    MSWordExportBase::OutputSectionBreaks: avoid fake section breaks
Comment 5 raal 2015-04-15 17:13:43 UTC
Created attachment 114813 [details]
printscreen 5.0+

I can confirm with Version:
Build ID: 51e0d789c344547956764c3b5f0ef5a304f4e0aa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-13_16:58:45
Comment 6 Timur 2015-05-07 06:59:44 UTC Comment hidden (obsolete)
Comment 7 Joel Madero 2015-05-11 18:41:31 UTC
My test results:

LibreOffice 3.3 (inherited from OOo)
MS Office 2010

I get the error all the way back to 3.3 (meaning that it's inherited). I'm not sure why regression tag is added as there is no proof that it ever worked without the dialog coming up. Removing regression and bibisectRequest.

Also - I see no reason why this is a Major bug - the file opens still, just Microsoft Repairs it (who knows what that actually means).


1) Why regression tag? What version worked? Please attach a working .doc file from some previous version of LibreOffice;

2) Why major? You pointed to the diagram but I don't actually see a justification here, the file opens in MS Office
Comment 8 Timur 2015-05-12 08:03:34 UTC
I'm sure I had those errors in the exact versions I noted. But, today, after testing on (regularly updated) Windows 7 with Office 2010, there are no errors.

I confirm that errors/repairs are shown on Windows 8.1 with Office 2013. I updated the title.
Comment 9 Xisco Faulí 2016-04-27 13:27:58 UTC
This issue is still reproducible in

Build ID: e7f55f15ccd97bc92e1400bc5862171a621da3e2
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-04-27_00:29:05
Locale: es-ES (es_ES)
Comment 10 Xisco Faulí 2016-11-18 19:04:11 UTC
I can no longer reproduce the issue in

Build ID: 757a60d01dd152aadab2ba3c8224252481ce8a88
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

Comment 11 Timur 2020-10-13 08:09:27 UTC
I reproduce same errors as in " printscreen " in MSO 2016 after saving in LO 7.1+.

Problem is that there are different errors, from "document based" bug approach. 
We need to go to "issue based" but hard to know exactly what Word repaired, it's mostly styles. 
I can only see Pictures, they are missing in MSO, probably because it were just pleceholders in LO and not missing linked pictures.
Comment 12 Timur 2020-10-13 08:15:48 UTC
Created attachment 166338 [details]
printscreen 7.1+