Bug Hunting Session
Bug 90450 - UI: Object Information in Status Bar does not display or open dialogues for some objects
Summary: UI: Object Information in Status Bar does not display or open dialogues for ...
Status: RESOLVED DUPLICATE of bug 91613
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.3.0
Keywords: bibisected, bisected, regression
Depends on:
Blocks: Statusbar
  Show dependency treegraph
 
Reported: 2015-04-04 14:43 UTC by Gordo
Modified: 2016-10-25 18:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-04-04 14:43:35 UTC
1. New Text Document.
2. Insert -> Image.
3. Click on image in document.
Result:
Object Information in Status Bar is blank.  Double clicking there does not bring up the Image dialogue.

4. Left click on image and left click again.
Result:
Overlapping numbers appear and disappear in Object Information in Status Bar.

5. Left click on image and left click again and hold briefly before releasing.
Result:
Overlapping numbers appear in Object Information in Status Bar.  Double clicking there does not bring up the Image dialogue.

The same happens with Formulas.

6. Insert -> Text Box.
7. Left click hold and drag Text Box in document.
Result:
Overlapping numbers appear and disappear in Object Information in Status Bar.
8. Resize Text Box.
Result:
Overlapping numbers appear and disappear in Object Information in Status Bar.

The same happens with Frames.

The overlapping happens when the window is not maximized.  Also on a small second monitor, the overlapping happens when the window is maximized.

Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Comment 1 A (Andy) 2015-04-04 20:12:29 UTC
Reproducible with LO 4.4.1.2, Win 8.1
Comment 2 Matthew Francis 2015-04-05 11:51:16 UTC
The behaviour in question changed across the two commits below.
After (1), the statusbar area at issue becomes too small and the contents are jumbled together
After (2), the content no longer displays except briefly when the image is clicked, and double clicking the area does nothing.

The change in behaviour seems to have been deliberate according to the referenced bug, but clearly there's still an inconsistency in what's left.
Adding Cc: to s.mehrbrodt@gmail.com; Could you possibly take a look at this? Thanks

(1)
    commit caaf28488fcca133db885ea0f7d324df9a716eac
    Author:     Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
    AuthorDate: Sat Nov 8 22:56:48 2014 +0100
    Commit:     Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
    CommitDate: Sat Nov 8 22:12:10 2014 +0000
    
        fdo#86018 Distribute space in statusbar better on small screens
    
        Change-Id: If07037e8d313c966c2db572716bf958c89c2fd79
        Reviewed-on: https://gerrit.libreoffice.org/12313
        Reviewed-by: Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
        Tested-by: Samuel Mehrbrodt <s.mehrbrodt@gmail.com>

(2)
    commit ebabf6d1fa648d62dd63529e9fe64dcb631caee8
    Author:     Samuel Mehrbrodt <s.mehrbrodt@gmail.com>
    AuthorDate: Sat Nov 8 23:02:11 2014 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Tue Nov 18 09:37:36 2014 +0000
    
        fdo#86018 Don't do anything when clicked on placeholder in statusbar
    
        No idea why this code got executed in sw, it has no action in sd and sc.
    
        Change-Id: I1d2b4b049f6ae6d117e7bf3464ae993c6951f1dc
        Reviewed-on: https://gerrit.libreoffice.org/12314
        Reviewed-by: Caolán McNamara <caolanm@redhat.com>
        Tested-by: Caolán McNamara <caolanm@redhat.com>
Comment 3 Matthew Francis 2015-04-05 11:52:36 UTC
...this time with the actual Cc:

Adding Cc: to s.mehrbrodt@gmail.com; Could you possibly take a look at this? Thanks
Comment 4 Robinson Tryon (qubit) 2015-12-13 11:12:12 UTC Comment hidden (obsolete)
Comment 5 Caolán McNamara 2016-07-29 09:30:18 UTC
The blank non-functional entry was fixed with the fix for tdf#91613

*** This bug has been marked as a duplicate of bug 91613 ***
Comment 6 Commit Notification 2016-07-29 09:51:56 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3a0aad2f5de3c78d0a3f0d6977903fbd41aa1d8f

Related: tdf#90450 don't overwrite text in size/pos statusbar item

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.