Bug 90465 - Transparency not preserved on chart type sample icons in insert chart wizard
Summary: Transparency not preserved on chart type sample icons in insert chart wizard
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Chart-Wizard Icon-Request
  Show dependency treegraph
 
Reported: 2015-04-05 15:27 UTC by Yousuf Philips (jay) (retired)
Modified: 2019-01-13 22:22 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot (39.45 KB, image/png)
2015-04-05 15:27 UTC, Yousuf Philips (jay) (retired)
Details
screenshot with master sources updated today (39.50 KB, image/png)
2015-04-06 19:53 UTC, Julien Nabet
Details
printscreen (34.55 KB, image/png)
2015-04-08 19:46 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-05 15:27:40 UTC
Created attachment 114633 [details]
screenshot

Step 1:
1) Open Calc with the tango testing icon theme
2) Insert A Chart
3) Select pie chart type
4) Notice the the first sample icon has a black background

Confirmed this happens on Linux and Windows on master.

Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-03-31_08:18:46
Comment 1 A (Andy) 2015-04-05 21:48:56 UTC
I see it in the screenshot, but unfortunately, I cannot reproduce it with LO 4.4.1.2, Win 8.1.
Comment 2 Yousuf Philips (jay) (retired) 2015-04-06 07:03:56 UTC
Can you include a screenshot Andy as i tested Windows 7 and saw the same black background behind the pie chart.
Comment 3 Julien Nabet 2015-04-06 19:53:48 UTC
Created attachment 114654 [details]
screenshot with master sources updated today

On pc Debian x86-64 with master sources updated today, I don't reproduce this.
Comment 4 A (Andy) 2015-04-06 20:02:40 UTC
@Julien: Thanks for your fast response!
@Jay: This normal view is also what I see.
Comment 5 Yousuf Philips (jay) (retired) 2015-04-06 20:32:32 UTC
(In reply to Julien Nabet from comment #3)
> On pc Debian x86-64 with master sources updated today, I don't reproduce
> this.

You arent reproducing it as you are not on the tango testing icon set. ;D

But even with your screenshot, the shadow behind each chart is supposed to be half the transparency of the chart border, but it is shown without transparency.
Comment 6 raal 2015-04-08 19:46:43 UTC
Created attachment 114690 [details]
printscreen
Comment 7 raal 2015-04-08 19:47:43 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: b024e36ddb3b53163d7a01f6f7b5aadb7a858cd9
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-03-31_09:12:20
Comment 8 Julien Nabet 2015-04-08 21:21:06 UTC
You're right Jay!
I gave a new try and reproduced this.

I noticed this console log:
warn:vcl.opengl:27340:1:vcl/source/opengl/OpenGLContext.cxx:466: Error: GLXBadFBConfig, Req: 156, Minor: 34

Markus: Thought you might be interested in this one. Also, if I can provide additional info to help (eg: glxinfo), don't hesitate to ask.
Comment 9 ace_dent 2015-07-01 21:58:07 UTC
Yep... so it was me 'breaking' those icons...
PNG images can be compressed in different formats, representing alpha transparency and colours in various ways. Different formats are favourable, depending on which yields the smallest file size. LibreOffice should support all those formats.

I had assumed all these issues had been caught since early OpenOffice days...
I've been doing this for 6 years(!). See:
http://portableapps.com/node/469
https://bz.apache.org/ooo/show_bug.cgi?id=60479

This has also affected some new Breeze icons. I will look at the PNG encoding.
Comment 10 ace_dent 2015-07-01 22:10:34 UTC
Ok, found the image:
/icon-themes/sifr/chart2/res/pie_52x60.png

But... it's actually just encoded in simple RGB+A... so really a standard format.
Code review is necessary to see if Alpha/ transparency is being respected at all for chart wizard images...

The reason this image stands out is due to the 'weird' colour smearing. This is actually just a (normally) invisible artefact for improving compression. i.e. this is expected behaviour. More info: http://encode.ru/threads/1260-CryoPNG-short-introduction
Comment 11 ace_dent 2015-07-01 22:21:28 UTC
Perhaps it's as simple as: 
/chart2/source/controller/dialogs/Bitmaps.src
- missing "MaskColor = STD_MASKCOLOR;" for most resources ...?
(Although not sure why it's still necessary anyway...)
Comment 12 QA Administrators 2016-09-20 10:14:17 UTC Comment hidden (obsolete)
Comment 13 Timur 2018-12-19 13:25:04 UTC
Please retest. I don't see icons at all in 5.4 in Mint but they are fine with 6.3+. Windows is fine. All without OpenGL.
Comment 14 andreas_k 2018-12-21 11:45:39 UTC
I know I draw there an white background to prevent this issue. All icons should get an review.
Comment 15 andreas_k 2019-01-13 22:22:39 UTC
there are no cart tango icons any more the fallback was used.