Bug 90479 - Loss of color backgrounds in some text frames when recording
Summary: Loss of color backgrounds in some text frames when recording
Status: RESOLVED DUPLICATE of bug 90130
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-04-06 12:38 UTC by laurentlepoittevin
Modified: 2015-04-09 03:25 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
exemple file (131.73 KB, application/vnd.oasis.opendocument.text)
2015-04-06 12:38 UTC, laurentlepoittevin
Details
print screen after save (78.51 KB, image/png)
2015-04-06 12:39 UTC, laurentlepoittevin
Details
print screen before save (80.40 KB, image/png)
2015-04-06 12:40 UTC, laurentlepoittevin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description laurentlepoittevin 2015-04-06 12:38:01 UTC
Created attachment 114646 [details]
exemple file

Then I changed the color of the background of some text frames, I record the document .odt format. When I open the file again, the colors of the background disappeared, replaced by white (not transparent).
tested libreoffice mac 4.4.2.2 and libreoffice 4.4.1.2 windows
Comment 1 laurentlepoittevin 2015-04-06 12:39:19 UTC
Created attachment 114647 [details]
print screen after save
Comment 2 laurentlepoittevin 2015-04-06 12:40:01 UTC
Created attachment 114648 [details]
print screen before save
Comment 3 Julien Nabet 2015-04-06 12:42:17 UTC
Not a blocker since not a crash.
Comment 4 Julien Nabet 2015-04-06 12:49:21 UTC
I could reproduce this on pc Debian x86-64 with master sources updated today.

I noticed this on console logs during opening and saving (trying to add a background):
warn:legacy.osl:22977:1:sw/source/core/doc/doclay.cxx:1552: Found a FlySection but not a Format!

I also noticed several times this during saving:
warn:legacy.osl:22911:1:xmloff/source/text/txtparae.cxx:3240: hyperlink without an URL --> no export to ODF
Comment 5 laurentlepoittevin 2015-04-06 13:12:24 UTC
Working properly with libreoffice 4.3.6.2 mac osx
Comment 6 Julien Nabet 2015-04-06 13:15:43 UTC
Indeed, if I open the file with LO Debian package 4.3.3, I can see the background.

Bug confirmed+regression+all platforms=>increase importance.
Comment 7 Matthew Francis 2015-04-09 03:25:06 UTC

*** This bug has been marked as a duplicate of bug 90130 ***