Download it now!
Bug 90569 - Crash:in Writer when copy-pasting a word in comment and save in docx
Summary: Crash:in Writer when copy-pasting a word in comment and save in docx
Status: RESOLVED DUPLICATE of bug 85769
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-04-11 19:45 UTC by Julien Nabet
Modified: 2015-04-22 17:31 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
console bt with master sources (11.76 KB, text/plain)
2015-04-11 19:45 UTC, Julien Nabet
Details
test file produced in comment #2 (4.73 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-04-18 20:06 UTC, Jean-Baptiste Faure
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Nabet 2015-04-11 19:45:33 UTC
Created attachment 114743 [details]
console bt with master sources

On pc Debian x86-64 with master sources updated yesterday, I've got a crash when doing this:
- open Writer with a brand new file
- type just a word
- copy the word
- select the only word typed + Insert comment
- paste the word in comment
- save as docx
Crash
Comment 1 Julien Nabet 2015-04-11 19:59:11 UTC
tdf#85769 (put in cc) shows the same except that in my case it crashed because I use debug mode.
Comment 2 Jean-Baptiste Faure 2015-04-14 04:26:23 UTC
Hi Julien,

Not reproducible for me with Version: 4.5.0.0.alpha0+
Build ID: cbbb24d0afcdbdac21d03ec4ee1455a3834afff4
built at home under Ubuntu 14.10 x86-64 (no debug mode).

Best regards. JBF
Comment 3 Julien Nabet 2015-04-14 19:57:10 UTC
Jean-Baptiste: your result could be expected but thank you for the test! :-)
Could you test the result on Word? (or test its validity in some way) I mean, I'm quite sure you've got some duplicate attribute in the file generated, more precisely in word/comments.xml (you can unzip it and try to open it in any web browser)
Comment 4 Buovjaga 2015-04-17 18:21:24 UTC
Reproduced.

Ubuntu 14.10 64-bit
Version: 4.5.0.0.alpha0+
Build ID: afb82d3729bda2754d0add08cc6c4dce1dc76d59
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-14_00:05:04
Locale: en_US
Comment 5 Jean-Baptiste Faure 2015-04-18 20:06:03 UTC
Created attachment 114894 [details]
test file produced in comment #2

Hi Julien,

(In reply to Julien Nabet from comment #3)
> Jean-Baptiste: your result could be expected but thank you for the test! :-)
> Could you test the result on Word? (or test its validity in some way) I
> mean, I'm quite sure you've got some duplicate attribute in the file
> generated, more precisely in word/comments.xml (you can unzip it and try to
> open it in any web browser)

In the attached file that I obtained in comment #2, I see that (in word/comments.xml):
<w:rFonts w:ascii="" w:hAnsi="" w:ascii="Liberation Serif" w:hAnsi="Liberation Serif" w:eastAsia="Droid Sans Fallback" w:cs="FreeSans"/>

Best regards. JBF
Comment 6 Jorendc 2015-04-22 17:31:39 UTC
Julien, see the comment of matus in bug 85769. (https://bugs.documentfoundation.org/show_bug.cgi?id=85769#c13)

-> marking as such.

*** This bug has been marked as a duplicate of bug 85769 ***