Bug 90574 - Does not display graphic in LibreOffice HTML document
Summary: Does not display graphic in LibreOffice HTML document
Status: RESOLVED DUPLICATE of bug 50763
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-11 23:53 UTC by Leon Arundell
Modified: 2015-04-17 17:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
HTML document with linked graphic (6.35 KB, text/html)
2015-04-11 23:53 UTC, Leon Arundell
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leon Arundell 2015-04-11 23:53:28 UTC
Created attachment 114744 [details]
HTML document with linked graphic

When saving an HTML document which includes a linked graphic, Writer embeds the graphic in the document. When it reopens the document, Writer does not display the graphic but instead displays the ASCII coding of the graphic file.

This can make it very difficult to edit the document.

To demonstrate these problems:

1. Use a web browser to copy the web page http://grapevine.net.au/~mccluskeyarundell/LSMember.html to your local disk.

2. Note that the file size is 6.5 kB.

3. Open the file in Writer. Note that it displays the graphic http://grapevine.net.au/~mccluskeyarundell/LivingStreetsLogo.jpg

4. Save the file as HTML Document (Writer).

5. Note that the file size has increased from 6.5 MB to 176 kB (because the linked graphic has become an embedded graphic).

6. Open the newly-saved file in Writer. Instead of displaying the graphic, Writer displays many pages of apparently random characters.
Comment 1 Buovjaga 2015-04-17 17:03:34 UTC
It seems this reopening problem has been fixed in a recent version. The fix appears to have been made to bug 50763.

The image is stored as a data URI: http://en.wikipedia.org/wiki/Data_URI_scheme#HTML

I tested on:

Win 7 Pro 64-bit, Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.2.2
Build ID: 40m0(Build:2)
Locale: en_US
Comment 2 Buovjaga 2015-04-17 17:05:24 UTC
Ehh.. should have marked as duplicate.

*** This bug has been marked as a duplicate of bug 50763 ***
Comment 3 Buovjaga 2015-04-17 17:06:49 UTC
The forced embedding is dealt in bug 48887.