Bug 90603 - rectangles with rounded corners imported incorrectly from visio
Summary: rectangles with rounded corners imported incorrectly from visio
Status: RESOLVED FIXED
Alias: None
Product: Document Liberation Project
Classification: Unclassified
Component: libvisio (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-14 06:06 UTC by Winfried Donkers
Modified: 2017-10-30 11:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
difference between Visio and Draw (9.35 KB, application/pdf)
2015-04-14 06:06 UTC, Winfried Donkers
Details
Visio document for testing (235.50 KB, application/vnd.visio)
2015-04-14 06:07 UTC, Winfried Donkers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2015-04-14 06:06:08 UTC
Created attachment 114773 [details]
difference between Visio and Draw

When importing Visio (vsd) drawings containing rectangular shapes with rounded corners, these are imported as rectangular shapes without rounded corners.
Attachment shows the difference.
Comment 1 Winfried Donkers 2015-04-14 06:07:34 UTC
Created attachment 114774 [details]
Visio document for testing

Visio document containing the rectangular shapes with rounded corners.
Comment 2 Fridrich Strba 2015-12-29 19:37:39 UTC
This libvisio commit http://cgit.freedesktop.org/libreoffice/libvisio/commit/?id=d62d8b5f13b31b55706ad35fe69a871847a163e1 fixes this issue. It will take some time before it is in LibreOffice, but closing it as I fixed it :)
Comment 3 Winfried Donkers 2016-01-05 08:14:12 UTC
(In reply to Fridrich Strba from comment #2)
> This libvisio commit
> http://cgit.freedesktop.org/libreoffice/libvisio/commit/
> ?id=d62d8b5f13b31b55706ad35fe69a871847a163e1 fixes this issue. It will take
> some time before it is in LibreOffice, but closing it as I fixed it :)

Thank you, Fridrich :-)
Comment 4 David Tardon 2016-01-18 09:40:39 UTC
*** Bug 97203 has been marked as a duplicate of this bug. ***