Bug 90615 - formula in pivot table gives erroneous result
Summary: formula in pivot table gives erroneous result
Status: RESOLVED DUPLICATE of bug 78503
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-14 16:01 UTC by Balazs Fekete
Modified: 2015-04-14 22:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Daily discharge data accumulated to monthly using pivot table (2.92 MB, application/vnd.oasis.opendocument.spreadsheet)
2015-04-14 16:01 UTC, Balazs Fekete
Details
printscreen (25.40 KB, image/png)
2015-04-14 17:36 UTC, raal
Details
Number alignment (623.24 KB, image/png)
2015-04-14 17:57 UTC, Balazs Fekete
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Balazs Fekete 2015-04-14 16:01:22 UTC
Created attachment 114789 [details]
Daily discharge data accumulated to monthly using pivot table

Computation in pivot table result spreadsheet don't work to compute running means. Cell F4 computes the sum of C3-C5 correctly, but when the division by three returns a wrong number in cell G4. The AVERAGE(C3-C5) returns the same wrong number as the dividing SUM(C3-C5)/3.
Comment 1 raal 2015-04-14 17:36:17 UTC
Created attachment 114792 [details]
printscreen

I can not confirm with LO 4.4.2, win7
Comment 2 Balazs Fekete 2015-04-14 17:56:14 UTC
I just realized that computation was correct, but the resulting number is aligned to the right of the cell showing decimals, while the leading two is hidden and becomes visible only when I make the column wider. I think the numbers should be left when there are two many digits that don't fit the cell.
Comment 3 Balazs Fekete 2015-04-14 17:57:47 UTC
Created attachment 114793 [details]
Number alignment

I just realized that computation was correct, but the resulting number is aligned to the right of the cell showing decimals, while the leading two is hidden and becomes visible only when I make the column wider. I think the numbers should be left when there are two many digits that don't fit the cell.
Comment 4 m.a.riosv 2015-04-14 22:32:32 UTC
Please verify if this is a reported issue in relation with the option for calc:
Menu/Tools/Options/LibreOffice cal/General - Use printer metrics for text formatting
is enable shows the issue, if disable not.

I think a duplicate.

*** This bug has been marked as a duplicate of bug 78503 ***
Comment 5 Balazs Fekete 2015-04-14 22:42:28 UTC
The "use printer metric" option is disabled. When I enable "use printer metric" it fixes the cell. When I disable, I have the same problem. Once I change the format of the field from general to something else, the field will display properly and will show ###s if there is not enough room. After changing the format, changing back to general fixes the problem and the cell still behaves properly.