Bug 90670 - android: Remove .res files from the .apk
Summary: android: Remove .res files from the .apk
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2015-04-17 08:04 UTC by Jan Holesovsky
Modified: 2018-02-19 17:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Holesovsky 2015-04-17 08:04:33 UTC
Turns out that we ship all the .res files with strings in the .apk.  We can decrease the .apk size by just avoiding them - or at least by hacking rsc so that that they actually contain only empty strings.
Comment 1 QA Administrators 2016-09-20 09:24:28 UTC Comment hidden (obsolete)
Comment 2 Tomaz Vajngerl 2017-03-04 22:06:01 UTC
Not that important as the maximum size of the APK was increased, but still good to implement eventually.
Comment 3 Rishabh Kalra 2018-02-14 14:12:25 UTC
Is the issue still active? If yes, i would like to take over the problem to submit the fix.
Comment 4 Xisco Faulí 2018-02-15 10:11:45 UTC
Hi Rishabh Kalra,
Once a bug is confirmed ('NEW') it shouldn't be moved to NEEDINFO, which means, we need feedback fro the reporter in order to confirm it.
If you interested in fixing this issue, please assign it to yourself and submit a patch to gerrit as explained here: https://wiki.documentfoundation.org/Development/gerrit/SubmitPatch
Thanks
Comment 5 Jan Holesovsky 2018-02-19 17:09:04 UTC
Invalid these days I think.