Bug Hunting Session
Bug 90717 - Calc crashes when deleting row number 11
Summary: Calc crashes when deleting row number 11
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) All
: high critical
Assignee: Eike Rathke
URL:
Whiteboard: target:5.1.0 target:5.0.0.3 target:4.4.5
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-04-19 16:57 UTC by dazky
Modified: 2016-10-25 19:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (15.14 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-04-19 16:57 UTC, dazky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dazky 2015-04-19 16:57:10 UTC
Created attachment 114913 [details]
Test file

Version: 4.4.2.2 
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd
EDITING

- open the file test.ods
- select the row number 11
- right-click and select delete row
Comment 1 raal 2015-04-19 17:16:55 UTC
I can confirm with Version: 5.0.0.0.alpha0+
Build ID: 89f5c1516fd3cf96488d97f62065b1ae0bdb9efa
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-18_10:10:39
Locale: cs_CZ

No crash with 4.3.3.2 -> regression
Comment 2 Julien Nabet 2015-04-19 19:21:11 UTC
Program received signal SIGSEGV, Segmentation fault.
0x00002aaaca85ba80 in sc::(anonymous namespace)::Notifier::operator() (this=0x7fffffff2fe0, pCell=0x700000000000010)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/core/tool/grouparealistener.cxx:33
33	        pCell->Notify(mrHint);
(gdb) bt
#0  0x00002aaaca85ba80 in sc::(anonymous namespace)::Notifier::operator() (this=0x7fffffff2fe0, pCell=0x700000000000010)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/core/tool/grouparealistener.cxx:33
#1  0x00002aaaca85d63e in std::for_each<__gnu_debug::_Safe_iterator<__gnu_cxx::__normal_iterator<ScFormulaCell**, std::__cxx1998::vector<ScFormulaCell*, std::allocator<ScFormulaCell*> > >, std::__debug::vector<ScFormulaCell*> >, sc::(anonymous namespace)::Notifier> (__first=, __last=, __f=...) at /usr/include/c++/4.9/bits/stl_algo.h:3755
#2  0x00002aaaca85d4c1 in sc::FormulaGroupAreaListener::notifyCellChange (this=0x3017f90, rHint=..., rPos=...)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/core/tool/grouparealistener.cxx:326
#3  0x00002aaaca85c680 in sc::FormulaGroupAreaListener::Notify (this=0x3017f90, rHint=...)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/core/tool/grouparealistener.cxx:120
#4  0x00002aaaaf46c9e9 in SvtBroadcaster::Broadcast (this=0x3039470, rHint=...) at /home/julien/compile-libreoffice/libreoffice/svl/source/notify/broadcast.cxx:136
#5  0x00002aaaca266e67 in ScBroadcastAreaSlotMachine::AreaBroadcast (this=0x2a18330, rHint=...)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/core/data/bcaslot.cxx:878
#6  0x00002aaaca4d43d3 in ScDocument::Broadcast (this=0x2a14228, rHint=...) at /home/julien/compile-libreoffice/libreoffice/sc/source/core/data/documen7.cxx:75
#7  0x00002aaacad947ee in ScDocShell::SetDocumentModified (this=0x2a141c0, bIsModified=true)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/docshell/docsh.cxx:2798
#8  0x00002aaacad95ba2 in ScDocShellModificator::SetDocumentModified (this=0x7fffffff37f0) at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/docshell/docsh.cxx:3083
#9  0x00002aaacad6e9c0 in ScDocFunc::DeleteCells (this=0x290d900, rRange=..., pTabMark=0x2ea78d0, eCmd=DEL_DELROWS, bRecord=true, bApi=false)
    at /home/julien/compile-libreoffice/libreoffice/sc/source/ui/docshell/docfunc.cxx:2542
Comment 3 Julien Nabet 2015-04-19 19:21:45 UTC
By looking at bt, it seems a dup of tdf#90694

*** This bug has been marked as a duplicate of bug 90694 ***
Comment 4 Eike Rathke 2015-06-27 00:59:48 UTC
Actually related, but not a duplicate.
Comment 5 Eike Rathke 2015-06-27 01:00:06 UTC
Taking.
Comment 6 Commit Notification 2015-06-27 01:22:19 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d8541c2a62121894bf87c91f1f89aea1ea30d680

tdf#90717 prevent crash, not really fixed

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-06-27 01:31:17 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=acb543b31dd7fe6c3370acec53e0710ed80a85f6&h=libreoffice-5-0

tdf#90717 prevent crash, not really fixed

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Eike Rathke 2015-06-27 01:32:04 UTC
Pending review for 4-4 at https://gerrit.libreoffice.org/16533
Comment 9 Commit Notification 2015-06-30 11:31:06 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=eb74c77c8ecc4521ae4d27e0ce4a2a651c38ab17&h=libreoffice-4-4

tdf#90717 prevent crash, not really fixed

It will be available in 4.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 steve -_- 2016-02-09 09:42:37 UTC
Eike, what's up with this old regression?

I just tested with latest master and had no problem deleting row number 11.

Version: 5.2.0.0.alpha0+
Build ID: e07ffae5046e9c91ef96026435cab84c3bcb4534
CPU Threads: 4; OS Version: Mac OS X 10.11.3; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-02-08_23:39:45
Locale: de-DE (de.UTF-8)

Setting to FIXED. Re-open if you disagree.