Download it now!
Bug 90724 - ACCESSIBILITY: Speak the footnotes
Summary: ACCESSIBILITY: Speak the footnotes
Status: RESOLVED DUPLICATE of bug 96481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-20 00:44 UTC by Jean-Philippe MENGUAL
Modified: 2015-12-28 15:00 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Philippe MENGUAL 2015-04-20 00:44:42 UTC
Hi,

   * What led up to the situation?

I inserted a footnote with LibreOffice Writer.

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

I can make Orca speak the number, in the text, mentioning the footnote.

   * What was the outcome of this action?

I'm unable to know that the number matches to.

   * What outcome did you expect instead?

I should see the footnote when the focus reaches the end of the page, or
having a footnotes list.
Comment 1 Robinson Tryon (qubit) 2015-04-23 14:18:15 UTC
(In reply to Jean-Philippe MENGUAL from comment #0)
> Hi,
> 
>    * What led up to the situation?
> 
> I inserted a footnote with LibreOffice Writer.
> ... 
> I can make Orca speak the number, in the text, mentioning the footnote.

Hi J-P,

What versions of LibreOffice and Orca are you using?

Status -> NEEDINFO
Comment 2 Jean-Philippe MENGUAL 2015-04-23 16:57:59 UTC
Hi,

I use Orca 3.14 or 3.16, on LibreOffice from 4.2.6 to 4.4.1. I experience the same behavior. I don't know if the LO sends the proper info to at-spi actually.

Regards,
Comment 3 Joanmarie Diggs 2015-04-23 17:13:07 UTC
It looks like the footnote number is part of the name of the object of role footnote. So I can add handling in Orca for that. But the displayed text for the footnote (e.g. "1") doesn't seem to be exposed anywhere else. It would be nice if it were. Then Orca can say "1 bla bla bla" if the user is arrowing within the footnote text.
Comment 4 Joanmarie Diggs 2015-04-23 19:19:40 UTC
Ah, I see that it's not a footnote role really; looks like ROLE_EXTENDED is being used. Role registration has been deprecated for a while now in ATK [1]. But I see we don't have a footnote role in ATK either. We should. I'll file an issue for that.

Lastly, when I tried this with Orca, Orca did announce the "1" as part of the text where the footnote was added ("Hello world 1"). So it is speaking the number in the text mentioning the footnote; what it's not doing is saying the "1" when you're at the bottom of the document reading the footnote. So it's not completely hopeless now. And with the changes I mentioned in ATK, LO, and Orca we'll improve it.

[1] https://developer.gnome.org/atk/unstable/AtkObject.html#atk-role-register
Comment 5 Jean-Philippe MENGUAL 2015-04-23 22:40:58 UTC
Hi,

Your summary is perfect. Just a detail: yes Orca says the number of the footnote, but actually, never the contents (it's very hard to hear it). On NVDA for example (on Office), the caret can go on the end of a page and read the number + contents matching to it while scrolling the footnotes. With LO on Linux, no. It would be nice to have at least this, or ideally, a binding to hear what a footnote matches to the number on which the caret is.

Best regards,
Comment 6 QA Administrators 2015-12-27 20:31:58 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 7 Joanmarie Diggs 2015-12-28 15:00:23 UTC
Marking this as a dup of bug 96481 (in which I describe some possible solutions which will make it possible for me to add the needed support in Orca for annotations, including footnotes).

*** This bug has been marked as a duplicate of bug 96481 ***