Bug 90786 - Spellchecker selected but not installed
Summary: Spellchecker selected but not installed
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.3.6.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-22 14:36 UTC by fios
Modified: 2016-10-25 19:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fios 2015-04-22 14:36:04 UTC
I just updated my LibreOffice from version LibreOffice_4.2.8_Win_x86 to LibreOffice_4.3.6_Win_x86.

As always, I chose the advanced options to make sure that my language's interface and spellchecker language (gd, Scottish Gaelic) were both selected.

I edited a document, no spell checking available. So, I ran the installer again and picked "Modify" to add the missing dictionary. It had already been selected, but I ran the process anyway.

Still, no spell checker, so I had a look at the extensions and it was indeed missing. I had to manually grab and install it from

https://extensions.libreoffice.org/extension-center/an-dearbhair-beag-scottish-gaelic-spellchecker
Comment 1 Aron Budea 2016-05-06 19:42:43 UTC
Can confirm.
I modified my LO 5.1.2 installation, and added Scottish Gaelic dictionary, but in Writer/Calc spell checker Scottish Gaelic still did not appear among the available languages.
Comment 2 Aron Budea 2016-05-06 21:05:00 UTC
Note to LO team: LO 5.1.2 comes with hunspell-gd v2.8, latest version is v2.9.
Comment 3 Michael Bauer 2016-05-06 21:16:47 UTC
Actually 3.1 by now :D
Comment 4 Aron Budea 2016-05-07 11:22:45 UTC
Nice! Something is weird on the extension page, though. If I access it now, it says 2.9 is the latest from almost two years ago. But if I google it, and open the cached version of the page, it says 3.1 is the latest from a few weeks ago.
Comment 5 Michael Bauer 2016-05-07 12:35:14 UTC
Dunno, the https link seems to point at odd version, the layout is really scrambled in Fx
https://extensions.libreoffice.org/extension-center/an-dearbhair-beag-scottish-gaelic-spellchecker

Whereas googling gets you to the http version of the page which seems fine
http://extensions.libreoffice.org/extension-center/an-dearbhair-beag-scottish-gaelic-spellchecker

Though I see 3.1 on both. <shrugs> the extension site is probably the one thing where OO remains way better than LO, I find the LO site really clunky and user unfriendly.
Comment 7 Aron Budea 2016-05-18 18:10:17 UTC
Fixed and updated the dictionary to 3.1 on master branch.
Will backport to LO 5.1 once I can actually test the install working, presumably when LO 5.2 beta is out.
Comment 8 Aron Budea 2016-07-28 06:45:12 UTC
https://gerrit.libreoffice.org/gitweb?p=dictionaries.git;a=commit;h=277e2326151aad0b97863bda696af33b371122f9

With that commit this should work fine in 5.2.
Since there's only going to be one more update to the 5.1 version after 5.1.5, I decided against backporting.