Bug Hunting Session
Bug 90789 - FILEOPEN:DOCX content messed up, all data from sections moved to last sections.
Summary: FILEOPEN:DOCX content messed up, all data from sections moved to last sections.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: All All
: medium major
Assignee: Vasily Melenchuk (CIB)
URL:
Whiteboard: target:6.0.0
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2015-04-22 19:47 UTC by Sushil Shinde
Modified: 2017-11-10 08:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
docx file contains 3 sections breaks and one frame on last page. (12.08 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-04-22 19:47 UTC, Sushil Shinde
Details
Screen shot for MS office. (Expected behaviour) (383.26 KB, image/png)
2015-04-22 19:48 UTC, Sushil Shinde
Details
Screen shot for LO writer. (Current behaviour) (384.39 KB, image/png)
2015-04-22 19:50 UTC, Sushil Shinde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sushil Shinde 2015-04-22 19:47:16 UTC
Created attachment 115012 [details]
docx file contains 3 sections breaks and one frame on last page.

Attached file contains three section breaks. When file opened on
latest LO master, It rendered all data from first two sections to
last section of the document. This is happening when one frame added
to last page of the document. If that frame removed from original file then
it worked properly. Its looks like LO messed it up if combinations of section break
and frame used in a file.
Comment 1 Sushil Shinde 2015-04-22 19:48:41 UTC
Created attachment 115013 [details]
Screen shot for MS office. (Expected behaviour)
Comment 2 Sushil Shinde 2015-04-22 19:50:11 UTC
Created attachment 115014 [details]
Screen shot for LO writer. (Current behaviour)
Comment 3 Alex Thurgood 2015-04-24 10:31:03 UTC
Confirming with :

Version: 5.0.0.0.alpha1+
Build ID: da36fc8c9564199b8c2f8f28c2e4d04d9862a2d4
TinderBox: MacOSX-10.10@61, Branch:master, Time: 2015-04-21_21:09:35
Locale: fr_

Also opened in Word 15.9.0 Preview on Mac where file displays as per poster's screenshot.
Comment 4 Xisco Faulí 2016-04-21 12:37:26 UTC
This issue is still reproducible in

Version: 5.2.0.0.alpha0+
Build ID: 3dca8575d63db50b0120fbff09bbfcd056fa3732
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-04-20_05:07:29
Locale: es-ES (es_ES)
Comment 5 Commit Notification 2017-10-08 23:59:06 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b98c65538e9d9079e0d0f97793db76759a057beb

tdf#90789 Anchored frames and shapes are identified by name/SdrObjects

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2017-10-10 17:34:39 UTC
Vasily Melenchuk committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c4d690b73b30aa144828935ad4e87eb13442d0c

tdf#90789: DOCX paragraphs in shapes like frames do not belong to section.

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Xisco Faulí 2017-11-10 08:06:10 UTC
A polite ping to Vasily Melenchuk (CIB): is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Thanks
Comment 8 Vasily Melenchuk (CIB) 2017-11-10 08:34:53 UTC
(In reply to Xisco Faulí from comment #7)
> A polite ping to Vasily Melenchuk (CIB): is this bug fixed? if so, could you
> please close it as RESOLVED FIXED ? Thanks

Ah yes, fixes were pushed to master. Fixed from my POV.