Download it now!
Bug 90793 - Fix the HiDPI wave underline character property
Summary: Fix the HiDPI wave underline character property
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.3.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2015-04-22 21:56 UTC by Keith Curtis
Modified: 2017-07-31 19:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Current wave underlines (10.83 KB, image/png)
2017-07-31 06:44 UTC, Keith Curtis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Curtis 2015-04-22 21:56:09 UTC
LibreOffice since 4.2.3 draws the spelling and grammar error waves lines nicely on HiDPI screens. This was done via changes to the OutputDevice::DrawWaveLine routine: http://opengrok.libreoffice.org/xref/core/vcl/source/outdev/textline.cxx#984

This fixes by far the most common use of this feature, but still we could do a better job for the underline character properties (wave, bold-wave, double-wave) which are hard-coded to draw 1 pixel and don't look very good. The relevant routine for this is OutputDevice::ImplDrawWaveLine

http://opengrok.libreoffice.org/xref/core/vcl/source/outdev/textline.cxx#88

I believe this is an easy hack. The first question is what widths to use. The spelling / grammar underlines are supposed to be unobtrusive, but the wave underline character property perhaps not. I would consider changing the code to use the underline / bold / double underline widths, or perhaps tweaks of them.
Comment 1 Robinson Tryon (qubit) 2015-12-14 05:00:16 UTC Comment hidden (obsolete)
Comment 2 Robinson Tryon (qubit) 2016-02-18 14:52:39 UTC Comment hidden (obsolete)
Comment 3 Robinson Tryon (qubit) 2016-03-03 14:35:11 UTC
(In reply to Keith Curtis from comment #0)
> I believe this is an easy hack.

Keith: Looks like you (originally) tagged this bug as an Easy Hack, but it still has a status of UNCONFIRMED. I'm going to put it into NEEDINFO, and ask that you or Jan triage this one (to NEW, or some other status).

Thanks!
Comment 4 Keith Curtis 2016-03-03 14:40:46 UTC
Yep, it's still needs to be fixed as of 5.1.x.
Comment 5 Xisco Faulí 2017-07-27 10:06:09 UTC Comment hidden (obsolete)
Comment 6 Keith Curtis 2017-07-31 06:44:35 UTC
Created attachment 135010 [details]
Current wave underlines
Comment 7 Keith Curtis 2017-07-31 06:45:39 UTC
The wave underlines appear better now. Including a screenshot.