Bug Hunting Session
Bug 90800 - [Graphite] Some fonts looks composing disorderly in LibreOffice for Windows
Summary: [Graphite] Some fonts looks composing disorderly in LibreOffice for Windows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsWindows8
Keywords:
Depends on:
Blocks: Font-Rendering
  Show dependency treegraph
 
Reported: 2015-04-23 05:46 UTC by Volga
Modified: 2016-08-04 02:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
They are taken from LO 4.4.2.2 (55.27 KB, application/zip)
2015-04-23 05:46 UTC, Volga
Details
Homepage of LibreOffice 5, with a record of opened file. (238.69 KB, image/png)
2015-08-07 09:13 UTC, Volga
Details
Opening fontfeatures.odt from the homepage of LO5 (320.48 KB, image/png)
2015-08-07 09:15 UTC, Volga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volga 2015-04-23 05:46:51 UTC
Created attachment 115024 [details]
They are taken from LO 4.4.2.2

Hi,

I found some fonts will composing disorderly after inputing feature ID in the LibreOffice for Windows. When I installed the LO in the first time, they looks proper; but when I launched again, the problem appeared, as my attachment shown on.
Comment 1 Buovjaga 2015-04-27 19:09:11 UTC
Could not reproduce (writing Qualifications with Linux Libertine G:liga=1).
Tested saving & reloading, too.

Might be worth trying this out: https://wiki.documentfoundation.org/User_Profile#Resolving_corruption_in_the_user_profile
Let us know, how it goes, if you rename your user profile.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.

Tested on:
Win 7 Pro 64-bit, Version: 4.4.3.1
Build ID: b2f347f2ac68821efc00b6f1793cda90af748118
Locale: fi_FI

Version: 5.0.0.0.alpha1+ (x64)
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-27_01:54:20
Locale: fi_FI
Comment 2 Volga 2015-04-28 04:00:24 UTC
Well, I have deleted all AppDatas of LibreOffice, then I open the LO Writer to test, the result looks the same as my attachment.

Tested on:
Win 8.1 64-bit, Version: 4.4.2.2
Locale: zh_CN

But when I made a test in my VMware virtual machine (Win 7 Ult 32-bit), the problem is disappeared.
Comment 3 Buovjaga 2015-04-28 05:58:04 UTC
Thanks.
This should be tested with Win 8.1 then. We actually have some Win 8-specific bugs :)
I'll set back to unconfirmed. I will test this on Win 8 at some point, but don't know the exact time, so other QA members are invited to test.
Comment 4 Volga 2015-04-28 06:53:11 UTC
I heard LO use some layout engines such as HarfBuzz on Linux, so what if porting them into LO for Windows?
Comment 5 Buovjaga 2015-04-28 15:20:56 UTC
Could not reproduce on Win 8.1 either.

I did not test on 4.4.2, but on 4.4.3 RC1 and 5.0 alpha, so maybe you could try with 5.0: http://dev-builds.libreoffice.org/daily/master/Win-x86@39/
It installs separately and will not mess with your profile.

Win 8.1 32-bit
LibO Version: 5.0.0.0.alpha1+
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86@39, Branch:master, Time: 2015-04-27_00:34:58
Locale: fi_FI
Comment 6 Volga 2015-04-28 17:54:30 UTC
Thanks!
I got LO 5.0 alpha to test, I found this bug looks resolved after I compare with 4.4.
Comment 7 Buovjaga 2015-04-28 18:04:04 UTC
(In reply to General Kutuzov from comment #6)
> Thanks!
> I got LO 5.0 alpha to test, I found this bug looks resolved after I compare
> with 4.4.

Nice! It seems 4.4.3 will also have the fix. You can already start using its RC1 version (installing it will overwrite your 4.4.2 version): http://www.libreoffice.org/download/pre-releases/

Release schedule: https://wiki.documentfoundation.org/ReleasePlan/4.4#4.4.3_release

I will mark this as WORKSFORME.
Comment 8 Volga 2015-04-29 11:38:31 UTC
Thank you, but one question is: all the feature IDs as my specified are not available for some font families such EB Garamond, FreeSans, FreeSerif, Linux Libertine O when I use LO for Windows, could you please fix it?
Comment 9 Buovjaga 2015-04-29 11:48:16 UTC
(In reply to General Kutuzov from comment #8)
> Thank you, but one question is: all the feature IDs as my specified are not
> available for some font families such EB Garamond, FreeSans, FreeSerif,
> Linux Libertine O when I use LO for Windows, could you please fix it?

That is bug 66916
Comment 10 Volga 2015-05-22 00:06:32 UTC
Oh~I got version 4.4.3.2, this issue is still appearing, then I try to delete my profiles, but the problem is still there.
Comment 11 Buovjaga 2015-05-22 05:11:09 UTC
(In reply to General Kutuzov from comment #10)
> Oh~I got version 4.4.3.2, this issue is still appearing, then I try to
> delete my profiles, but the problem is still there.

How about 5.0 beta? http://dev-builds.libreoffice.org/pre-releases/win/x86/?C=S;O=D;P=*5.0.0.0*
Comment 12 Volga 2015-05-22 07:14:55 UTC
(In reply to Beluga from comment #11)
> (In reply to General Kutuzov from comment #10)
> > Oh~I got version 4.4.3.2, this issue is still appearing, then I try to
> > delete my profiles, but the problem is still there.
> 
> How about 5.0 beta?
> http://dev-builds.libreoffice.org/pre-releases/win/x86/?C=S;O=D;P=*5.0.0.0*

Well, I got this pre-release, this issue is not appearing when I input several phrases to test, then I opened a ODT file from Linux Libertine website, many of them works well, except a discretionary ligature for digraph "ij" and a kerning feature for italic correction "itlc".

[1] http://www.numbertext.org/linux/
Comment 13 Volga 2015-05-22 07:21:31 UTC
I also rested with FreeSerif, this issue still unresolved.
Comment 14 Buovjaga 2015-05-22 07:25:20 UTC
Ok, changing back to unconfirmed then.
Comment 15 Volga 2015-06-23 17:02:25 UTC
Oh~ well, this bug is still appearing in LO 5.0.0.1 when I open this file:

http://www.numbertext.org/linux/fontfeatures.odt
Comment 16 Volga 2015-08-06 16:42:00 UTC
OK, this is resolved in LobreOffice 5, but still having some small problems when I get fontfeatures.odt from Comment 15.
Comment 17 Volga 2015-08-07 09:13:51 UTC
Created attachment 117734 [details]
Homepage of LibreOffice 5, with a record of opened file.
Comment 18 Volga 2015-08-07 09:15:43 UTC
Created attachment 117735 [details]
Opening fontfeatures.odt from the homepage of LO5
Comment 19 Volga 2015-08-07 09:16:29 UTC
I think I was known what was happened, If I open the fontfeatures.odt from the homepage (as my attachment shown) firstly, this bug is appeared, but when I created a document firstly, this bug is disappeared.
Comment 20 Volga 2015-09-07 03:07:24 UTC
This bug is still appeared in LO 5.1 on Windows 10. In this case fontfeatures.odt displayed incorrect in these ways:
    File --> Open
    File --> Open recent file
    Opening from launcher

But if you opening file through double-click, this file looks correct.
Comment 21 Volga 2015-11-07 07:55:12 UTC
(In reply to General Kutuzov from comment #15)
> Oh~ well, this bug is still appearing in LO 5.0.0.1 when I open this file:
> 
> http://www.numbertext.org/linux/fontfeatures.odt

I am using LO 5.0.3 on Windows 10 now, this file works well only after opening file by double-click, otherwise only OpenType feature (such as standard ligatures and kerning) work.
Comment 22 Volga 2016-03-10 19:14:47 UTC
On Windows 10, I have tested LO 5.1.1, using fontfeatures.odt. If you have already opened the main program, the file would not proper (as Attachment 117735 [details]); if you opened the file directly by double-klick from folder, the file would looks proper.
Comment 23 Volga 2016-03-16 06:12:44 UTC
(In reply to General Kutuzov from comment #22)
> On Windows 10, I have tested LO 5.1.1, using fontfeatures.odt. If you have
> already opened the main program, the file would not proper (as Attachment
> 117735 [details]); if you opened the file directly by double-klick from
> folder, the file would looks proper.

Version: 5.1.1.3 (x64)
Build ID: 89f508ef3ecebd2cfb8e1def0f0ba9a803b88a6d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: zh-CN (zh_CN)
Comment 24 Volga 2016-08-01 02:48:35 UTC
This bug seems fixed to me.

Version: 5.1.5.2 (x64)
Build ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: zh-CN (zh_CN); Calc: group
Comment 25 Buovjaga 2016-08-01 07:35:04 UTC
Thanks, let's close.
Comment 26 Volga 2016-08-04 02:32:29 UTC
(In reply to Buovjaga from comment #25)
> Thanks, let's close.

Thanks. I hope new common SAL layout would performanced better.