Bug 90805 - TOOLBAR: Enabling border color on an image should enable border
Summary: TOOLBAR: Enabling border color on an image should enable border
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other All
: medium minor
Assignee: Justin L
URL:
Whiteboard: target:7.4.0 target:7.3.0.0.beta2
Keywords: preBibisect, regression
Depends on:
Blocks: Writer-Images Toolbar-Border-Controls
  Show dependency treegraph
 
Reported: 2015-04-23 07:24 UTC by Yousuf Philips (jay) (retired)
Modified: 2021-12-21 11:37 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2015-04-23 07:24:11 UTC
Steps:
1) Open Writer
2) Insert Image
3) Set the border color in the toolbar
4) Image will shrink due to the spacing to content being set to 0.02" (0.05cm) (bug 90070)
5) No border wasnt enabled and color wasnt added to it

Regression as it works in 3.3.0, though i couldnt figure how it works correctly as opening the Format > Picture dialog's border tab doesnt have borders set or the border color selected set.

Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58
Comment 1 Buovjaga 2015-04-25 14:19:50 UTC
Yep, it already happens with 3.5.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f3375fa07f27bd2ade519af3c07d69040d10eaa9
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-22_23:38:50
Locale: fi_FI

Ubuntu 15.04 64-bit
OpenOffice.org 3.3.0
OOO330m20 (Build:9567)

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 Robinson Tryon (qubit) 2015-12-14 05:40:07 UTC Comment hidden (obsolete)
Comment 3 Buovjaga 2020-09-30 18:24:32 UTC
Still repro

Arch Linux 64-bit
Version: 7.1.0.0.alpha0+
Build ID: 09c24681a3414092fde50ec0f617c9f7c79e8a61
CPU threads: 8; OS: Linux 5.8; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 30 September 2020
Comment 4 Aron Budea 2021-08-14 04:15:54 UTC
(In reply to Buovjaga from comment #1)
> LibreOffice 3.5.0rc3 
> Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Already happens with 3.4.0, too.
Comment 5 Justin L 2021-12-16 10:03:54 UTC
proposed fix at http://gerrit.libreoffice.org/c/core/+/126910
Comment 6 Commit Notification 2021-12-16 14:08:49 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/9f93a26c23ae21324f2389a18512d71d3d610b99

tdf#90805 sw: if no border when adding border color, add hairline

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2021-12-16 15:27:48 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/6ce377a649c8db7576dbb7a30949d0f89c08439f

related tdf#90805 sw table: ensure border when setting border color

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Buovjaga 2021-12-16 17:11:58 UTC
Verified, thx

Arch Linux 64-bit
Version: 7.4.0.0.alpha0+ / LibreOffice Community
Build ID: ab4ee55a2a03ce93debcda41d817a95517a711f0
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: kf5 (cairo+xcb)
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 16 December 2021
Comment 9 Samuel Mehrbrodt (allotropia) 2021-12-20 08:44:41 UTC
Maybe we should use the 0.5pt line (Thin) instead of 0.05 (Hairline) border by default as we now do for tables (see bug 99027).
Comment 10 Justin L 2021-12-20 10:13:55 UTC
(In reply to Samuel Mehrbrodt (allotropia) from comment #9)
> Maybe we should use the 0.5pt line (Thin) instead of 0.05 (Hairline) border
For images (and thus also frames and ole objects), my commit message says:
    Due to things like bug 90070 (since LO scales down an image when
    adding a border), only make this a hairline border.
    Otherwise, a larger default would seem reasonable...

For tables, using the same change you just made seems reasonable/consistent.
Comment 11 Commit Notification 2021-12-20 13:14:15 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/68fdfc6013126526f5ba3908c5ad762f18f463cf

tdf#90805 sw: if no border when adding border color, add hairline

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2021-12-20 13:15:30 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/f314a882c96cc0e951fecb83be73a03ef3f33da1

related tdf#90805 sw table: ensure border when setting border color

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2021-12-21 08:30:41 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/3807e43b3b1a05eb7d9c88988b41448cfc05015a

tdf#90805 sw tables: use veryThin instead of hairline borders

It will be available in 7.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2021-12-21 11:37:18 UTC
Justin Luth committed a patch related to this issue.
It has been pushed to "libreoffice-7-3":

https://git.libreoffice.org/core/commit/40b84167a58901d50d98730260d968046283376c

tdf#90805 sw tables: use veryThin instead of hairline borders

It will be available in 7.3.0.0.beta2.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.