Download it now!
Bug 90821 - UI: different behaviour for 'insert row/column' for Writer and Calc
Summary: UI: different behaviour for 'insert row/column' for Writer and Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-23 20:20 UTC by Vitaliy Lotorev
Modified: 2017-08-21 15:01 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
printscreen (22.18 KB, image/png)
2015-04-24 04:17 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaliy Lotorev 2015-04-23 20:20:24 UTC
There is different behaviour for 'insert row' (also 'insert column') in Writer (while editing tables) and Calc.

1) In Calc 'insert row' create new blank row at cursor and moves previously current line down.
While in Writer 'insert row' creates new blank row *after* previously current line.

2) Final cursor position is also different for both apps.

Below is simple illustration for behaviour: three rows with data 'a', 'b', 'c', cursor is set on
row 'b'.

====================================
Calc (before 'insert row'):

a
b (cursor here)
c
====================================
Calc (after 'insert row'):

a
  (new blank row created here, cursor is left on the same row)
b
c
====================================
Writer (before 'insert row'):

a
b (cursor here)
c
====================================
Calc (after 'insert row'):

a
b (cursor is still here)
  (new blank row created here)
c

====================================


IMHO, the Calc's behaviour is more natural (can't describe why, is's just IMHO).

Just checked Microsoft Office: it has different menu actions: insert row below (writer's behaviour),
insert row above (calc's behaviour).
While on ribbon interface 'insert row above' has big icon, and 'insert row below' has small icon
(probably MSO think that 'insert row above' should be used more often?)

Anyway, my key concern is the same button 'insert row' must be consistent across applications
and perform the same action. Current behaviour makes user think each time what application he/she is using
and what behaviour to expect and whether current row is properly selected or he/she should move one row down/up.
Comment 1 raal 2015-04-24 04:17:03 UTC
Created attachment 115045 [details]
printscreen

Hello,
you can add row above with right click. button behaviour is probably because of ability to add new last line.

Writer (before 'insert row'):

a
b 
c (cursor here)
====================================
Writer (after 'insert row'):

a
b 
c  (cursor is still here)
d (new blank row created here)

====================================
Comment 2 Vitaliy Lotorev 2015-04-24 13:36:46 UTC
thanks raal, but the bug is not about 'how to insert row above'.

The question is behaviour for "insert row" GUI button should be the same: it has the same icon for button and and almost the same icon text ('insert rows' for Calc and 'insert row' for Writer).
Comment 3 V Stuart Foote 2015-04-27 01:20:38 UTC
*** Bug 90883 has been marked as a duplicate of this bug. ***
Comment 4 V Stuart Foote 2015-04-27 01:29:38 UTC
As Calc sheets/cells/rows/columns are completely different data objects to Writer table/cells/rows/columns there is nothing wrong or unexpected with the current state of the UI.

One can make an argument for UI enhancement that the cell/row/column selection, insertion, and deletion should respond the same between Cells and Tables--the fact that we use the same .uno command names and icons just strengthens the argument for consistent behavior.

But folks should be aware that would require considerable rework of either Tables or Sheets or both to bring them in line.
Comment 5 Yousuf Philips (jay) (retired) 2015-04-27 08:16:26 UTC
Just so happens that i submitted a patch today to include what behaviour is being done, as i found it confusing as well that Calc and Writer did opposite insertions but the tooltips didnt indicate this.

https://gerrit.libreoffice.org/#/c/15545/

Also submitted an enhancement for the creation of new insert commands for writer that would have the same insert behaviour as calc (bug 90882).
Comment 6 Robinson Tryon (qubit) 2016-08-25 05:26:53 UTC Comment hidden (obsolete)
Comment 7 Heiko Tietze 2017-08-21 15:01:24 UTC
Issue has been fixed according comment 5 with Insert below/after or left/right respectively.