Bug 90842 - not able to open old 2007 ODF file (Courier font problem)
Summary: not able to open old 2007 ODF file (Courier font problem)
Status: RESOLVED DUPLICATE of bug 98989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta1
Hardware: All Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 93743 (view as bug list)
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2015-04-24 18:38 UTC by Oliver Lehmann
Modified: 2017-11-04 11:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
odt file which can't be displayed with Writer (52.63 KB, application/vnd.oasis.opendocument.text)
2015-04-24 18:38 UTC, Oliver Lehmann
Details
PDF file showing how it should look like (123.62 KB, application/pdf)
2015-04-24 18:39 UTC, Oliver Lehmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Lehmann 2015-04-24 18:38:54 UTC
Created attachment 115075 [details]
odt file which can't be displayed with Writer

On opening old odf files I've created back in 2007 with OO.org 2.3, the first page is displayed, but on scrolling to the 2nd or 3rd page, Writer freezes and only displayes a white page.
I've to kill the process. I tried several files from 2007 - all with the same result.

Please find an example ODF file attached and the PDF file showing how it should look like (created in 2007 with OO.org 2.3 PDF export)
Comment 1 Oliver Lehmann 2015-04-24 18:39:21 UTC
Created attachment 115076 [details]
PDF file showing how it should look like
Comment 2 raal 2015-04-24 19:33:08 UTC
I can confirm with Version: 5.0.0.0.alpha1+
Build ID: 636c5a63d67b52b0d2f9f21a863c45eca6ac9ff7
TinderBox: Win-x86@42, Branch:master, Time: 2015-04-21_23:00:42

Works OK in Linux Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-22_01:28:24
Comment 3 Oliver Lehmann 2015-04-24 19:48:52 UTC
To be more specific:
The file was created with OpenOffice.org 2.3 (680m5 Build-9221) on FreeBSD

I also tried opening the file with the Apache OpenOffice 4.1.1 on Windows.
It opens the file (but the layout is mangled).
Comment 4 Oliver Lehmann 2015-04-24 20:24:20 UTC
It also works with OO.org 3.0.1 on FreeBSD.

I guess it is related to the font used in the Document. When I change the font to "Courier New" in OO.org 3.0.1 and save the document, it can be opened with LibreOffice on Windows.
Comment 5 raal 2015-04-24 20:49:12 UTC
Works OK with Verze: 4.2.8.2
ID build: 48d50dbfc06349262c9d50868e5c1f630a573ebd
win7
regression
Comment 6 Michael Stahl (CIB) 2015-05-18 20:15:28 UTC
in last week's master build on Windows, it does not hang for me

but the document looks indeed quite mangled, and using a different
font fixes that

on Linux however current master / 4.4 / 4.3.7 / 4.2.8 all
display it properly

presumably it's a Windows specific font handling problem - font
rendering has platform specific backends
Comment 7 Timur 2015-08-28 14:12:23 UTC
*** Bug 93743 has been marked as a duplicate of this bug. ***
Comment 8 Timur 2015-08-28 14:20:30 UTC
It can be solved with adding font change from "Courier" to "Courier New" in Tools-Options-Fonts. But, Bug 64509 looks like a real solution.
Although, I don't undestand why it wasn't a problem in 4.3.7.
Comment 9 Robinson Tryon (qubit) 2015-12-14 05:32:33 UTC Comment hidden (obsolete)
Comment 10 Michael Stahl (CIB) 2016-04-07 12:44:59 UTC
Courier problem is fixed now

*** This bug has been marked as a duplicate of bug 98989 ***