Download it now!
Bug 90887 - Ability to Collapse Sections of Text Based on Style/Outline Formatting
Summary: Ability to Collapse Sections of Text Based on Style/Outline Formatting
Status: RESOLVED DUPLICATE of bug 38093
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-27 01:12 UTC by oldman.documentfoundation
Modified: 2015-04-27 09:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description oldman.documentfoundation 2015-04-27 01:12:04 UTC
This isn't a bug report, it is a suggestion for what I would consider an improvement to the Writer component of Libre Office.  Many years ago I bought a package of CD's that had educational tutorials, it was back in the days of Windows 95, so a long time ago.

In this package was a program called Term Paper, which was to help the student write outlines for Term Papers and such.  When I am writing an outline, and with many others I would assume as well, I like to whip up the outline with all it's levels and sub-levels quickly, and then fill in the details in a block of un-numbered text under it later.  And, to minimize distraction of having too many levels of the outline open as well as keeping the outline from stretching out over a number of pages when working on it, I like to have the ability to collapse or hide the descriptive text for all the outline items except the one I am working on - yet have the ability to open any other item as well if I need to refer to it for some reason.

The 'Term Paper' software worked exactly like this.  You could whip up the outline with all levels and sublevels quickly, and then have one/multiple/all levels open depending on how you wanted to work.  I thought this was a wonderful way to outline, and I would like to see a similar functionality in Writer.  Yes, I know that there are lots of outline programs out there, many of them free - single pane, double pane, etc.  But I have been unable to find one that worked in quite this way before.

Also, I think adding in this functionality to Writer would greatly enhance it's usability to the everyday user, and make Libre Office that much more appealing and useful to everyday users.  As it stands, from what I have been able to learn from reading/posting in user forums, this might or might not be possible, if you're going to do it you have to do this or that complicated change to fields or study up on how to create your own fields - which in addition to burning up a lot of time learning to code that an everyday user just probably isn't going to want to spend on an office suite package.  Not to mention once you get someone who doesn't know what they're doing in there mucking about with things like this you have the danger of messing up your entire install and having to re-install all over again.  You can maybe possibly do it, according to what some say in the user support forums, using hidden text but it is a big complicated mess as well - and after you do get it to working it is an all or nothing proposition, either all hidden text viewed and your list accordian's out like a roman scroll, or everything is collapsed.

So, I am just wondering how hard it would be to actually build this functionality into Writer.  This was an old small program that did not take up much disk space at all, just a couple of kilobytes in size.  I don't know if that would mean it would be a relatively easy function to add into Writer, or if in today's coding environment it would mean a huge chunk of code would have to be written and integrated into the package.

But, if it wouldn't be too hard to add this into Writer, I think it would be a very useful tool for users who do a lot of outlining.  Thanks.
Comment 1 Joel Madero 2015-04-27 06:27:30 UTC
A couple points here:

1. Seems like a valid enhancement so moving it to NEW;

2. In the future - less text is better ;) We have thousands of bug reports to deal with, reading paragraphs of text (with a ton of basically irrelevant background info) can result in lots of QA members skipping the bug because no one has the time/energy/patience to read so much when we're doing it all day every day :)

3. In terms of difficulty, would be quite hard and probably unlikely to be implemented


So I'll move to NEW because it's valid with the warning that it's unlikely to be implemented unless a volunteer with some serious skills decides to tackle a large project like this.


Thanks for the suggestion.
Comment 2 Cor Nouws 2015-04-27 09:16:21 UTC
(there are already some dup reports for this one)

*** This bug has been marked as a duplicate of bug 38093 ***