Bug 90888 - SIDEBAR: Shrink the properties sections in Calc
Summary: SIDEBAR: Shrink the properties sections in Calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Rishabh
QA Contact:
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2
Keywords:
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2015-04-27 04:44 UTC by Yousuf Philips (jay)
Modified: 2016-10-24 16:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
trimmed down sidebar (37.92 KB, image/png)
2015-04-27 04:44 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2015-04-27 04:44:36 UTC
Created attachment 115127 [details]
trimmed down sidebar

The content in the 4 open sections (Character, Number Format, Alignment, Cell Appearance) of the properties tab in the sidebar in calc are so long that they dont fit on my 1440x900 screen resolution or lower, so it would be useful trim their contents.

Number Format:
* Removal of 'Category:' label as its redundant
* Move the number, percentage and currency buttons to the right of the number format drop down and remove the date and label buttons as they are not as frequently used and are easily selectable in the drop down

Alignment:
* Removing/Hiding the 'text orientation:' subsection or alternatively just leaving the label and the angle rotation field.

Cell Appearance:
* Removing 'show cell grid lines' checkbox as its not a property of a cell but is of the sheet and its is not a frequently unused feature
* Removing 'cell border:' label as its redundant

It would also be nice to change the label 'Cell background' to just 'Background' as the section is already called 'Cell Appearance'. Also the label 'Left indent' should be changed to 'Indent' as it stores the indent value whether it is from the right or left indent, as it is similarly labeled in the dialog.

The attached mockup comes to a height of about 600 pixels which will fit sufficiently on lower end screen resolutions (e.g. 1280x768) if the formatting toolbar was hidden.

Having a smaller sidebar will also benefit in the future when a styles section is added to provide easily selectability of cell styles.
Comment 1 Joel Madero 2015-04-27 06:24:12 UTC
Moving straight to NEW per procedures for UX suggestions.
Comment 2 Heiko Tietze 2015-04-27 09:01:49 UTC
(In reply to Jay Philips from comment #0)
> Number Format:
> * Removal of 'Category:' label as its redundant
Every control should have a caption in order to make it accessible via hotkey (alt+C here). I'd remove the dropdown since it's redundant to the buttons below, that are a better mean to quickly change the format. However, in this case the label makes no sense anymore.

PS: Hotkey access at the sidebar is completely broken (by design?). We need a guideline here.

> Alignment:
> * Removing/Hiding the 'text orientation:' subsection or alternatively just
> leaving the label and the angle rotation field.

Most frequently used orientation setting should be 90°. All other options may be accessed via dialog.

> Cell Appearance:
> * Removing 'show cell grid lines' checkbox as its not a property of a cell
> but is of the sheet and its is not a frequently unused feature

Agreed

> * Removing 'cell border:' label as its redundant

Same as above
Comment 3 Yousuf Philips (jay) 2015-04-30 21:53:02 UTC
(In reply to Heiko Tietze from comment #2)
> (In reply to Jay Philips from comment #0)
> > Number Format:
> > * Removal of 'Category:' label as its redundant
> Every control should have a caption in order to make it accessible via
> hotkey (alt+C here). I'd remove the dropdown since it's redundant to the
> buttons below, that are a better mean to quickly change the format. However,
> in this case the label makes no sense anymore.

The section heading 'Number Format' is the caption, which is why 'Category:' is redundant. The dropdown has 10 entries in it and there are 5 buttons, so buttons provide easy access to frequently used entries in the drop down without opening it and the drop down provides a few more options which are less frequent.

> PS: Hotkey access at the sidebar is completely broken (by design?). We need
> a guideline here.

The sidebar isnt a hotkey driven interface, it is a mouse driven interface IMHO.

> > Alignment:
> > * Removing/Hiding the 'text orientation:' subsection or alternatively just
> > leaving the label and the angle rotation field.
> 
> Most frequently used orientation setting should be 90°. All other options
> may be accessed via dialog.

So are you suggesting a 90° checkbox?
Comment 4 Heiko Tietze 2015-05-01 09:47:37 UTC
(In reply to Yousuf (Jay) Philips from comment #3)
> The sidebar isnt a hotkey driven interface, it is a mouse driven interface

Being mouse driven only affects accessibility for disabled persons but also quick access via keyboard. Do we really want this? (Ben and Eve wouldn't rely on the keyboard only).
 
> So are you suggesting a 90° checkbox?

No checkbox but a (speed) button that rotates clockwise by 90°.
Comment 5 Yousuf Philips (jay) 2015-05-01 15:09:54 UTC
(In reply to Heiko Tietze from comment #4)
> Being mouse driven only affects accessibility for disabled persons but also
> quick access via keyboard. Do we really want this? (Ben and Eve wouldn't
> rely on the keyboard only).

So i checked with the gnome a11y team and they said the sidebar isnt accessible friendly, so i think leaving it as a mouse only interface is a good way to have it as the toolbars are accessibility friendly. With the mouse being the only means of dealing with the sidebar, there isnt a need for quick access via keyboard shortcuts.

> No checkbox but a (speed) button that rotates clockwise by 90°.

I'm assuming you mean the spin buttons with up and down arrows, and if that is true, then i'd stick with the current control we have as you can easily jump to a preset value with 2 clicks rather than many more with a spin button.
Comment 6 Heiko Tietze 2015-05-04 10:00:08 UTC
(In reply to Yousuf (Jay) Philips from comment #5)
> > No checkbox but a (speed) button that rotates clockwise by 90°.
> 
> I'm assuming you mean the spin buttons with up and down arrows

Nope. One click = one rotation, 4 clicks = "reset" (360° rotation)
Comment 7 Yousuf Philips (jay) 2015-05-07 10:54:20 UTC
(In reply to Heiko Tietze from comment #6)
> Nope. One click = one rotation, 4 clicks = "reset" (360° rotation)

What does a speed button look like?
Comment 8 Commit Notification 2015-06-02 14:10:02 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c18deee371ae21088383b2a2ddc55c7a7fd41b7

tdf#90888:Shrink the properties sidebar sections in Calc

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-06-07 13:07:43 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e00e9ac78a61199337910e1b0cee19722c2eefe&h=libreoffice-5-0

tdf#90888:Shrink the properties sidebar sections in Calc

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.