Bug 90917 - Table cell with border padding on left edge disappearing under text
Summary: Table cell with border padding on left edge disappearing under text
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2015-04-28 19:13 UTC by Janusz
Modified: 2020-03-19 08:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
example of the bug (10.49 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-04-28 19:13 UTC, Janusz
Details
screenshot of the error (56.27 KB, image/png)
2015-04-28 19:13 UTC, Janusz
Details
printscreen (113.92 KB, application/pdf)
2015-04-29 08:07 UTC, raal
Details
The document in current master at 100% zoom (59.46 KB, image/png)
2020-03-18 12:54 UTC, NISZ LibreOffice Team
Details
The document in current master at 120% zoom (59.29 KB, image/png)
2020-03-18 12:55 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Janusz 2015-04-28 19:13:05 UTC
Created attachment 115167 [details]
example of the bug

table created in MS Word, opened in libre office, text in the cells is being drawn over left cell border, when border is shown, then there is a blank.
Comment 1 Janusz 2015-04-28 19:13:38 UTC
Created attachment 115168 [details]
screenshot of the error
Comment 2 raal 2015-04-29 08:07:39 UTC
Created attachment 115174 [details]
printscreen

I can confirm with LO 4.4.2, win7

Duplicate of bug 77796 ?
Comment 3 Buovjaga 2015-04-29 16:21:32 UTC
Jay said this isn't a dupe of his bug.. setting to NEW.
Comment 4 QA Administrators 2016-09-20 09:36:50 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2019-12-03 14:37:41 UTC Comment hidden (obsolete)
Comment 6 Timur 2019-12-09 14:24:00 UTC
Repro 6.5+. Lowering priority.
Text wasn't there is Lo 3.6, already wrong in LO 4.0. Not a regression, but bibisect would be useful.
Same if docx resaved in MSO.
Comment 7 NISZ LibreOffice Team 2020-03-18 12:54:57 UTC
Created attachment 158781 [details]
The document in current master at 100% zoom

To me it looks more like a rendering glitch, as it depends on zoom level. With current master (but also in 5.4.0 and all newer versions) it looks good at 100% zoom, but the missing line segments start to appear if zoom is changed to 80-90-110-120-130% etc.
Comment 8 NISZ LibreOffice Team 2020-03-18 12:55:45 UTC
Created attachment 158782 [details]
The document in current master at 120% zoom

Everything is the same except zoom is 120%
Comment 9 NISZ LibreOffice Team 2020-03-18 14:49:52 UTC
Changing meta bug. Also happens if the example is saved to odt. Problem is triggered by the 0 left cell border padding on Table Properties - Borders tab.