Bug 90952 - Cannot print or view directly without editing at column B9 - B11 in example file
Summary: Cannot print or view directly without editing at column B9 - B11 in example file
Status: RESOLVED DUPLICATE of bug 78503
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-30 03:37 UTC by Prikitiew
Modified: 2015-05-08 04:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Cannot print or view directly without editing at column B9 - B11 (23.50 KB, application/vnd.ms-excel)
2015-04-30 03:37 UTC, Prikitiew
Details
Sample file modified. (9.50 KB, application/vnd.ms-excel)
2015-04-30 20:19 UTC, m.a.riosv
Details
Characters missing when viewing & print this protected file. (23.50 KB, application/vnd.ms-excel)
2015-05-07 10:51 UTC, Prikitiew
Details
workaround (135.30 KB, image/png)
2015-05-07 12:45 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Prikitiew 2015-04-30 03:37:24 UTC
Created attachment 115204 [details]
Cannot print or view directly without editing at column B9 - B11
Comment 1 raal 2015-04-30 08:05:35 UTC
The problem is in height of row. Your test is two lines and height of row is only one line and Calc show second line. Second line is empty. I see no bug here.
Comment 2 Prikitiew 2015-04-30 10:15:33 UTC
Thank you for your soon reply.
Sorry, I don't know if it's not bug.

From the test file, as you say, I know  it's consist of : 
two lines and height of row is
only one line and Calc show second line. Second line is empty.
It was deliberately made that way.

This file just an examples.
Please you can check, These Characters (in B8, B9, B10, B11, B12) can be Visible/Print with "OpenOffice Calc or Microsoft Office Excel".
If opened with LibreOffice Calc => not visible to the complete & even can not Print directly without editing these characters

This would be a big problem : if we want to View or Print Agreement Letter/others,  because it seem some characters missing and cannot print directly.

I hope there is solver on next version.
Thanks for your help.
Comment 3 Prikitiew 2015-04-30 10:24:33 UTC
(In reply to raal from comment #1)
> The problem is in height of row. Your test is two lines and height of row is
> only one line and Calc show second line. Second line is empty. I see no bug
> here.


It will be better if Libreoffice Calc : show from First Line, then second line .. etc.
How to do that way ? 
Thank you.
Comment 4 m.a.riosv 2015-04-30 20:19:02 UTC
Created attachment 115228 [details]
Sample file modified.

All you need to do is set up the Vertical alignment for those cells to Top instead default as it is in your sample file.
Comment 5 Prikitiew 2015-05-07 02:26:30 UTC
(In reply to m.a.riosv from comment #4)
> Created attachment 115228 [details]
> Sample file modified.
> 
> All you need to do is set up the Vertical alignment for those cells to Top
> instead default as it is in your sample file.

Thank you for your clue.
But actually I have received "the file" with need password to modify.
I try to modify the vertical alignment but it can't be done because password protected.
The protected file come from another person which I just received, then I can only show and print as a document.

Please give us suggestion how we can solve the problem.
Thanks again for your help.
Comment 6 Prikitiew 2015-05-07 10:51:40 UTC
Created attachment 115403 [details]
Characters missing when viewing & print this protected file.

This protected file just can view or print only.
So there was problem (in cells B8-12) to view/print the first line.
Because the cells can not modify.
The problem not happened if the file opened with Open Office Calc or Microsoft excel.
If needed, password to modify => this protected file is 123
Please help to solve this problem.

Sorry, if this is not bug, please tell me, where I can ask to others and upload this file. Please give me the site address.
Thank you very much.
Comment 7 raal 2015-05-07 12:45:01 UTC
Created attachment 115409 [details]
workaround

nasty workaround: select whole page; click on the icon Themes; select theme Standard

But it's a bug in LO / when sheet is locked should not be possible to change sheet.
Comment 8 m.a.riosv 2015-05-07 13:49:59 UTC
I think founded where the issue came from.

Disable the option:
Menu/Tools/Options/LibreOffice calc/General - Use printer metrics for text formatting.

It's an already reported bug, with different effects.

*** This bug has been marked as a duplicate of bug 78503 ***
Comment 9 Prikitiew 2015-05-08 04:53:27 UTC
(In reply to m.a.riosv from comment #8)
> I think founded where the issue came from.
> 
> Disable the option:
> Menu/Tools/Options/LibreOffice calc/General - Use printer metrics for text
> formatting.
> 
> It's an already reported bug, with different effects.
> 
> *** This bug has been marked as a duplicate of bug 78503 ***

I just see the setting :
Tools/Options/LibreOffice calc/General - Use printer metrics for text formatting.
Currently, the setting default is uncheck (disable).

Then I give "checkmark" to enable "Use printer metrics for text formatting".
Previously : Characters missing when viewing & print this protected file => Now the characters can viewing normally, but for temporary.

If I close the file, and then open again the protected file => The Characters missing again when viewing & print.
Then I tried "uncheck / disable" again "Use printer metrics for text formatting",  => it can viewing normally for temporary again.

Again, I close the file, and then open the protected file => The Characters missing again when viewing & print.
......
I received the file from other people, So I don't know where the characters can be lost / missing.

Considering that I just received the protected files (so many) from other people which I don't know the password. So, I can not modify / change the sheet content to resolve the problem. So confusing, because I can only viewing & print the protected file.

I hope it can be solved for next version of LibreOffice soon.

Thanks again for everyone. I'm very appreciate for your help & attention.