Bug 90959 - Icons with menus in the Drawing Toolbar misaligned when the toolbar is orientated vertically
Summary: Icons with menus in the Drawing Toolbar misaligned when the toolbar is orient...
Status: RESOLVED DUPLICATE of bug 90455
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-30 10:15 UTC by Gabriel Diosan
Modified: 2016-05-03 06:14 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of icons in the Drawing Toolbar misaligned (134.65 KB, image/png)
2015-04-30 10:15 UTC, Gabriel Diosan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Diosan 2015-04-30 10:15:16 UTC
Created attachment 115214 [details]
Screenshot of icons in the Drawing Toolbar misaligned

Icons with menus in the Drawing Toolbar misaligned when the toolbar is orientated vertically

- Steps to reproduce: -

1. Open LibreOffice Draw or Writer
2. Ensure that the Drawing Toolbar is visible and aligned vertically (on the left side in this case)

- Current Behaviour -

When looking at the icons which can have an expanded selection/menu such as "Curves & Lines" and "Arrows", the arrow that is used to expand the selection/show the menu:

1. Points downward when it should be pointing to the side (right hand side in this instance); and
2. Is situated along the side of the icon throwing off the alignment of the icon when compared to others in the toolbar.

- Expected Behaviour -

1. The arrows should point to the side when the Drawing Toolbar is aligned vertically; and
2. The arrows should be situated beneath or above the icon to retain a consistent vertical alignment between all icons in the Drawing Toolbar.

- Tested with: -

LibreOffice 4.2.8 from the Ubuntu 14.04 repo

LibreOffice 4.4.2 from the Ubuntu 15.04 repo

LibreOffice Version: 5.0.0.0.alpha1+
Build ID: 010b2d2d9be846fb6b10848204e29e1bc00ef1ea
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-04-29_23:54:29
Locale: en_AU.UTF-8

- Attachment -

I have attached a screenshot showing the issue and some suggested changes.

- Other Comments -

UX Advice is likely required on this one.

Gabriel
Comment 1 Buovjaga 2015-04-30 15:18:37 UTC
True. Vertical orientation is default in 5.0.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: f0edb677f09ad338e22ac3b5d91497b4479e0b3c
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-27_01:54:20
Locale: fi_FI
Comment 2 Adolfo Jayme 2016-05-03 06:14:24 UTC

*** This bug has been marked as a duplicate of bug 90455 ***