Bug 91020 - Trendline not visible if first X-value is text (comment 8)
Summary: Trendline not visible if first X-value is text (comment 8)
Status: RESOLVED DUPLICATE of bug 76649
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-02 13:32 UTC by andis.lazdins
Modified: 2015-06-10 20:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Trendline not visible in chart (18.93 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-02 13:32 UTC, andis.lazdins
Details
printscreen from 5.0 (26.66 KB, image/png)
2015-05-03 07:01 UTC, raal
Details
Pivot tables with correct and wrong charts (40.28 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-03 08:16 UTC, andis.lazdins
Details
Example of chart with invisible trend line (28.13 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-06-05 16:57 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2015-05-02 13:32:17 UTC
Created attachment 115269 [details]
Trendline not visible in chart

I use pivot tables to create XY scatter charts. Once I realized that after reorganizing pivot table one of trendlines is not visible any more. The regression equation and R2 of the trendline shows certain values, which means that something is calculated. It is not possible to get visible trendline for that data set at any way except creating new chart.

Trendline is not visible even if the chart is copied to another document. Sample chart, copied to another spreadsheet is attached to this report.

Ubuntu 32 bit, Libreofffice 4.4.3.2
Comment 1 raal 2015-05-03 07:01:29 UTC
Created attachment 115281 [details]
printscreen from 5.0

Printscreen of 5.0

I see red trend line, but I should see also blue trendline? I cannot add new trendline into data series E.  Please attach test file with pivot table and chart.
Comment 2 andis.lazdins 2015-05-03 08:15:31 UTC
(In reply to raal from comment #1)
> Created attachment 115281 [details]
> printscreen from 5.0
> 
> Printscreen of 5.0
> 
> I see red trend line, but I should see also blue trendline? 

Yes, that is missing.

I cannot add new
> trendline into data series E.  Please attach test file with pivot table and
> chart.

Unfortunately, it is not existing any more. I deleted wrong chart from original file. The attached file is reconstruction of what I did. The first sheet contains original pivot and chart with 2 visible trendlines. Second sheet contains updated pivot and chart with visible 1 trendline. After changing pivot I rearranged data sources in the chart, but it didn't affect visibility of the second trendline.
Comment 3 andis.lazdins 2015-05-03 08:16:12 UTC
Created attachment 115283 [details]
Pivot tables with correct and wrong charts
Comment 4 raal 2015-05-03 11:41:43 UTC
Your charts are not linked to pivot table, they have own Chart data table. Please provide a clearer set of step-by-step instructions on how to reproduce the problem. thanks

I tried to change values in Chart data table, copy table and trend line is still present.
Comment 5 andis.lazdins 2015-05-03 13:08:51 UTC
Probably it is enough to consider a problem, because it is not possible to make visible trendline in the first attached file?

As soon as I'll have same free time I'll create sample file.
Comment 6 GerardF 2015-05-03 15:15:44 UTC
I see what is causing the problem.
Trendline is not visible when data for X is empty in 1st row of data table.

Edit the chart with missing trenline and show data table.
You will see no value X in row 1. Enter any value and the trendline appears.
Comment 7 andis.lazdins 2015-05-03 17:15:31 UTC
Thank you!

It looks easy to solve.
Comment 8 Laurent BP 2015-06-05 16:57:08 UTC
Created attachment 116313 [details]
Example of chart with invisible trend line

Description: Trendline not visible if first value of X-value is text.

Steps to reproduce:
1. Enter XY data with a first line of text
2. Select data with labels in fist line and Insert Chart
3. In wizard, Select XY (Scatter), Next
4. Uncheck "First row as label" (label is now considered as data), Finish
5. Right click on the series > Insert Trend line (let default option), OK

Actual behavior:
Trendline is invisible

Expected behavior:
Trend line should be visible, as it is expected when you check trend line equation.

A workaround is to modify Data Ranges, as indicated in Comment 6, to remove the first line from X-values, or to check "First line as label".

Test made with Version: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
Comment 9 Laurent BP 2015-06-10 16:57:43 UTC
Confirmed with Version: 4.3.2.2
Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d
Comment 10 Laurent BP 2015-06-10 17:00:09 UTC
Confirmed with Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale : fr-FR (fr_FR)
Comment 11 Laurent BP 2015-06-10 19:16:10 UTC
Confirmed with:
- Version: 4.2.0.0.alpha0+
Build ID: cb14b1e56d2aab70d28afca8bf039a27f89671c8
TinderBox: Win-x86@6, Branch:master, Time: 2013-07-11_04:05:08
- Version: 4.2.0.0.alpha0+
Build ID: 4a8f7ddc290d1ea3131de6611b6833b77ac7ab1f (2013-08-28)
- Version: 4.2.0.0.beta1
Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
- Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

NOT confirmed with:
- Version: 4.2.0.0.alpha0+
Build ID: 4ba92ec1d565848c86c5e802b30f17862ad6505f (2013-06-27)
- Version: 4.1.6.2
Build ID: 40ff705089295be5be0aae9b15123f687c05b0a

Note that equation is visible, but not the trend line. If file is exported to XLS, Excel is able to see the trendline. If file is opened with
Comment 12 Laurent BP 2015-06-10 20:47:01 UTC

*** This bug has been marked as a duplicate of bug 76649 ***