Download it now!
Bug 91024 - EDITING: Calc freeze sort
Summary: EDITING: Calc freeze sort
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 92085 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-02 14:57 UTC by brian.phillip.ward
Modified: 2015-06-15 14:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description brian.phillip.ward 2015-05-02 14:57:15 UTC
This may be a duplicate of bug 90757, though does not result in a complete crash.  I am running Libreoffice  4.2.8.2 on Linux Mint 17.1.  Since the last update of LO 4.2.8, sorting any spreadsheet typically takes a very long time (several minutes).  

The problem is apparent when highlighting all cells in a sheet, and then sorting by any column (with "range contains column labels" checked).  The spreadsheet will freeze for several minutes, and LO will be completely unresponsive during that time.  The sort will eventually finish correctly.

I have had this problem with multiple files, whether they are in native format or xlsx format.
Comment 1 m.a.riosv 2015-05-02 18:42:48 UTC
Seems a duplicate, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 90757 ***
Comment 2 Eike Rathke 2015-05-04 19:23:05 UTC
@Brian:
Do not select all cells, which is the cause for the slow performance here. Select only the range to be sorted, or just place the cell cursor in such range and Calc will select the range for you.

Actually this is not a duplicate of bug 90757, but a fix is available only as of 4.3.something and later.
Comment 3 brian.phillip.ward 2015-05-04 19:59:06 UTC
Thank you for your response Eike, I will keep that in mind from now on.  Will likely be updating at least to 4.3 or later if it is included with the next version of Linux Mint.
Comment 4 m.a.riosv 2015-06-15 14:19:22 UTC
*** Bug 92085 has been marked as a duplicate of this bug. ***