Bug Hunting Session
Bug 91093 - EMF with alpha blend bitmap
Summary: EMF with alpha blend bitmap
Status: RESOLVED DUPLICATE of bug 91017
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.1 all versions
Hardware: Other All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-05 08:11 UTC by Andras Timar
Modified: 2016-02-02 21:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc (DOCX) (28.61 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-05-05 08:11 UTC, Andras Timar
Details
screenshot Word vs. LibreOffice (37.15 KB, image/png)
2015-05-05 08:11 UTC, Andras Timar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-05-05 08:11:15 UTC
Created attachment 115334 [details]
bugdoc (DOCX)

The attached bugdoc contains an embedded OLE object (PDF file). In the document, the embedded OLE object is displayed as an icon, which is EMF. The background of the bitmap should be white/transparent, but it is black in LibreOffice 4.1 and higher. The icon is not displayed at all in earlier LibreOffice versions, so it is probably not a regression. 

The EMF file contains EMR_ALPHABLEND record (AlphaBlend GDI call), and I think the problem is that transparency is not handled by LibreOffice's bitmap processing code. 

Bug 90539 was similar, but there was possible to use a hack.
Comment 1 Andras Timar 2015-05-05 08:11:48 UTC
Created attachment 115335 [details]
screenshot Word vs. LibreOffice
Comment 2 Buovjaga 2015-05-07 13:51:10 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+ (x64)
Build ID: 98436c4b53639d86f261ac630c46d32e3c7b8e28
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-05-04_00:07:10
Locale: fi-FI (fi_FI)
Comment 3 Andras Timar 2016-02-02 21:58:06 UTC

*** This bug has been marked as a duplicate of bug 91017 ***