Bug 91098 - SCM friendly file format
Summary: SCM friendly file format
Status: RESOLVED DUPLICATE of bug 88298
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-05 17:12 UTC by Ed Braaten
Modified: 2015-05-11 07:02 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Panley-Munson ACM paper on version-aware file format (388.35 KB, application/pdf)
2015-05-05 17:12 UTC, Ed Braaten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ed Braaten 2015-05-05 17:12:08 UTC
Created attachment 115362 [details]
Panley-Munson ACM paper on version-aware file format

LibreOffice Writer doesn't offer a Source Code Management (SCM) friendly file format for saving documents.  Popular SCM's such as git, svn, etc. see the current file formats as binary blobs and therefore can't do simple text diffs of changes between document revisions.  Meenu Pandey and Ethan V. Munson have published an ACM paper proposing a version-aware LibreOffice document format, however this solution doesn't solve the problem of storing documents in an SCM-friendly format which is being asked for in this enhancement request.
Comment 1 Adolfo Jayme 2015-05-05 19:37:11 UTC
Very interesting paper! Thank you very much.
Comment 2 David Tardon 2015-05-05 20:35:43 UTC
There is Flat ODF.
Comment 3 David Juran 2015-05-06 07:24:56 UTC
Not having read the paper, in my opinion, the Flat ODF format is still not a perfect fit. Among other issues, it is rather "chatty" with e.g. a time-stamp embedded in every save which makes diff:in and merging challenging.

In my opinion, we should keep this RFE open to decide what to do with it. Modifications to the Flat ODF? A new format? Or something entirely different...
Comment 4 David Tardon 2015-05-11 07:02:43 UTC
A new libreoffice-specific document format is the last thing we want.

*** This bug has been marked as a duplicate of bug 88298 ***