Bug 91146 - Empty image after exporting Writer page to PNG or JPEG
Summary: Empty image after exporting Writer page to PNG or JPEG
Status: RESOLVED DUPLICATE of bug 90604
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: bisected
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-05-07 21:12 UTC by daniel.plachotich
Modified: 2015-05-21 11:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.plachotich 2015-05-07 21:12:57 UTC
After exporting Writer page as image, it's absolutely empty: JPEG is white and PNG is fully transparent.
Comment 1 A (Andy) 2015-05-09 07:11:24 UTC
Reproducible with LO 4.4.2.2, Win 8.1

Steps done:
1. Open WRITER
2. Write a few words
3. Go to FILE -> EXPORT
4. There test it by selecting jpg and png as file formats and export these files
5. In the thereafter opened Properties dialog box press OK
6. Open the png and jpg file

Result: Both are empty.
Comment 2 MM 2015-05-09 10:00:42 UTC
Confimed with v4.4.3.2 under mint 17.1 x64.
Unconfimed with v4.3.7.2 under mint 17.1 x64.

So regression.

The text is gone, but when selecting png the background is always transparent, also on older versions. Another bug or by design ?
Comment 3 Michael 2015-05-18 17:12:39 UTC
Seems related to this bug

https://bugs.documentfoundation.org/show_bug.cgi?id=90604
Comment 4 Michael 2015-05-18 17:51:20 UTC
git bisect selects commit 2ce0aededea43231d91a0955fc0676120dcc4f13

$ git bisect log
# bad: [cf6ea17155fabb2a120ba07c150735591ac861d7] source-hash-3f94c9e9ddfd807b449f3bb9b232cf2041fa12d2
# good: [fc71ac001f16209654d15ef8c1c4018aa55769f5] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect start 'latest' 'oldest'
# good: [8cf60cc706948588e2f33a6d98b7c55d454e362a] source-hash-f340f0454627939f1830826fb5cc53a90e6c62a4
git bisect good 8cf60cc706948588e2f33a6d98b7c55d454e362a
# good: [7beddf3808dadd525d7e55c00a5a90a2b44c23d3] source-hash-2f10386ce577f52e139aa23d41bc787d8e0b4d59
git bisect good 7beddf3808dadd525d7e55c00a5a90a2b44c23d3
# bad: [fb3ec529b3f37f0c7eab2e9b7a9cc695c0f27676] source-hash-0516d123f53917d1833c7e8a8c528a619c71a0af
git bisect bad fb3ec529b3f37f0c7eab2e9b7a9cc695c0f27676
# good: [74c2960deb8278b16021ff39bb8b8b58fa887351] source-hash-d4867ddae67def9a52d7e3e027e261323f32c8f9
git bisect good 74c2960deb8278b16021ff39bb8b8b58fa887351
# bad: [fa3c391991dca0f1e8e3db8393f3564625959ce4] source-hash-3bdee6495ebc7f515d6d297e7f7df9a46acc3880
git bisect bad fa3c391991dca0f1e8e3db8393f3564625959ce4
# good: [e39d1b31e6bc92451823f0c9445b77ed32eac06c] source-hash-91fac2a32c1c6b784bd33cf664ea64a734b1c776
git bisect good e39d1b31e6bc92451823f0c9445b77ed32eac06c
# good: [26ef59063b4bf46eba0b32d629ad1a2165b24fe9] source-hash-5d78c65851d8da14b6370a40393b3fb8367d7e1a
git bisect good 26ef59063b4bf46eba0b32d629ad1a2165b24fe9
# bad: [54db96969f217663c4aadf8b12e0e6356cf77c9d] source-hash-52d98d8e716cf59eb4a8cbdec11d42d47608e6bb
git bisect bad 54db96969f217663c4aadf8b12e0e6356cf77c9d
# good: [70146e6b674e8b6b2a32794599adf7d301e2aa17] source-hash-8c5f640308b618ec330e83527019a4baa982f902
git bisect good 70146e6b674e8b6b2a32794599adf7d301e2aa17
# bad: [63e58b679265ced107b528a7f31fc3c9e86ea35b] source-hash-3efc3cc5b0b4b6151e928c2348c7dc6f74181db5
git bisect bad 63e58b679265ced107b528a7f31fc3c9e86ea35b
# bad: [6c7cdd0c7ec2a71305b197b3e4194eafc81227d9] source-hash-9b1dda187be0057a9d87c1ef95da2ee4db905449
git bisect bad 6c7cdd0c7ec2a71305b197b3e4194eafc81227d9
# bad: [6f7b6e0c265ca2cec1384713de9d018606ac6188] source-hash-ddc7f5dda51b100e69a8e7d86c0f8144ed3d8ea5
git bisect bad 6f7b6e0c265ca2cec1384713de9d018606ac6188
# bad: [44b279071e6297f4722276167029f3499038c05a] source-hash-2ce0aededea43231d91a0955fc0676120dcc4f13
git bisect bad 44b279071e6297f4722276167029f3499038c05a
# first bad commit: [44b279071e6297f4722276167029f3499038c05a] source-hash-2ce0aededea43231d91a0955fc0676120dcc4f13
Comment 5 Michael Stahl (CIB) 2015-05-21 11:10:08 UTC

*** This bug has been marked as a duplicate of bug 90604 ***