Download it now!
Bug 91189 - Impossible to import Access 2007/2010 Databases
Summary: Impossible to import Access 2007/2010 Databases
Status: RESOLVED DUPLICATE of bug 43187
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: wantBacktrace
Depends on:
Blocks: Database-Import
  Show dependency treegraph
 
Reported: 2015-05-09 17:26 UTC by Henri
Modified: 2017-10-23 08:24 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Access 2010 database (376.00 KB, application/msaccess)
2015-10-06 11:28 UTC, Henri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henri 2015-05-09 17:26:55 UTC
Upon trying to import Access 2010 databases (which are in Access 2007 format), the following error appears: "SQL-Status: HY000 // Die Verbindung konnte nicht hergestellt werden. Möglicherweise ist der benötigte Datenprovider nicht installiert." Nothing at all is imported, the new *.odb databases are empty.
The same error appears with all my databases I tried.
Comment 1 m.a.riosv 2015-05-09 20:09:07 UTC
Hi @Henri,

and what is you LibreOffice version.

Can you attach a little sample file to test.
Comment 2 m.a.riosv 2015-05-09 20:09:31 UTC
Hi @Henri,

and what is your LibreOffice version.

Can you attach a little sample file to test.
Comment 3 Robert Großkopf 2015-05-10 07:58:50 UTC
How did you try to import the tables? Is Base connected to the access-database?
If you try to import data from one database to another both databases have to be *.odb-files. One is the *.odb-file for the connection to an external database and the other is the *.odb-file for the tables, which should be imported into the internal HSQLDB (or any other database ...).
Comment 4 Henri 2015-05-24 10:01:51 UTC
LibreOffice (4.4.2.2) starten - Base Datenbank klicken.
Datenbank-Assistent - Verbindung mit existierenden Datenbank - Microsoft Access 2007 - Durchsuchen - [Schritt 2] Fertigstellen - [Schritt 2] Speichern unter
• da kommt die zweizeilige Fehlermeldung LibreOffice Base:
Die Verbindung zur Datenquelle "ABC" konnte nicht hergestellt werden.
Die Verbindung konnte nicht hergestellt werden. Möglicherweise ist der benötigte Datenprovider nicht installiert.

NB: Es wird sehr wohl eine ABC.odb Datei angelegt (2KB). Keine Abfragem, Formulare oder Berichte. Bei Klicken auf "Tabellen" kommt wieder obere Fehlermeldung.

Die Original-Access 2010-Datenbank hat 880 KB. Es handelt sich aber um vertrauliche Daten (Adressen). Der Fehler ist aber der gleiche auch mit allen anderen .ACCBD-Datenbanken, die allerdings viel zu gross sind für Beilagen (>315 MB) !
Comment 5 MM 2015-06-03 23:38:20 UTC
Confirmed with v4.4.4.1 under windows 7 x64. 

Download and unpack: http://www.ms-access2010.com/tutorials/Access2010DB.zip

Steps to reproduce:

1) Start Base.
2) Select 'connect to an existing database' > 'microsoft access 2007'
3) Next
4) Browse > pick one of the downloaded files (.accdb), doesn't matter which one. > Open.
5) Next
6) Default settings will do.
7) Finish
8) Select database for saving.

Now you got the error: 'The connecttion to the data source "[your filename]" could not be established. The connection could not be created.........'

If you press "more" you get 2 errors:
 1 - The connection to the data source "[your filename]" could not be established.
 2 - SQL Status: HY000  The connection could not be created. May be the necessary data provider is not installed.

If you select 'microsoft access' and from the examples, 'AgeRange.mdb', you can make a connection.
Comment 6 Timur 2015-06-04 14:37:31 UTC
MM's comment looks like a duplicate of Bug 43187, see https://bugs.documentfoundation.org/show_bug.cgi?id=43187#c14 
I don't know whether Henri's report is about the same problem.
Comment 7 MM 2015-06-04 18:47:45 UTC
Well no-one said anything about the error on display. Only that there was a problem when Access opened the same file as LO at the same time, and that LO couldn't write to that file. Or did I misunderstood that ?!
Comment 8 Henri 2015-10-06 11:28:39 UTC
Created attachment 119350 [details]
Access 2010 database

Update LibreOffice 5.2.2.0 :

Now with the newest LibreOffice version the behaviour is different: upon saving as *.odb file there is an immediate crash and the error message: "LibreOffice crashed through an unexpected error …". The recovery works but as soon as I click on Tables in the recoverd db, the same crash occurs again and again !

NB: this is independent of the Access database contents. I could reproduce the error with a test database containing only 1 text field and one record (attached).
Comment 9 Julien Nabet 2016-05-06 14:10:45 UTC
Henri: 5.2.2 hasn't been released yet, I suppose you meant 5.1.2

Anyway, could you rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X) + use this link to retrieve bt (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Mac_OSX:_How_to_get_debug_information).

Jean-Pierre: knowing you working on Access2Base, thought you might be interested in this one.
Comment 10 Julien Nabet 2016-05-29 13:40:39 UTC
A backtrace/stacktrace may be useful here.
(see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)
Comment 11 Alex Thurgood 2016-06-03 07:50:51 UTC
This bug report is a complete mess. The last input from Henri was 8 months ago.
Not quite sure why there is a reference to purging one's OSX user profile ?

Anyway, I would be inclined to mark as DUP of 43187

*** This bug has been marked as a duplicate of bug 43187 ***
Comment 12 Henri 2016-06-09 05:38:02 UTC
UND WAS NOCH ? Ich habe nun Version 5.0.6.3 (x64) installiert, der gravierende Bug ist IMMER NOCH DA , nun wird der Crash etwas verständlicher !

LibreOffice Base - Datenbank-Assistent - Verbindung zu bestehende Datenbank - Microsoft Access 2007 (NB: ich verwende Access 2010, das Format sollte aber 2007 sein) - Weiter - Durchsuchen - …\Test.accdb - Weiter - Nicht anmelden / Zur Bearbeitung öffnen - Fertigstellen

Es öffnet sich "Speichern unter" : …\Test.odb

Früher war da ein Absturz mit folgender Wiederherstellung (ohne irgendwelche Fehlermeldung), das wiederholte sich beim Klicken auf eine beliebige Tabelle nach der Wiederherstellung.

Jetzt in der neuen Version 5.0.6.3 kommt neu eine Warnmeldung: Die Verbindung zur Datenquelle "Neue Datenbank" (NICHT "Test" !) konnte nicht hergestellt werden, möglicherweise Datenprovider nicht installiert.

MS Office 2010 Pro ist bei mir installiert, allerdings seit kurzem in der ×32-Version (Office 2010 ×64 hat zuviele Bugs). Aber wenn LibreOffice ×64 keine Datenbank aus MS Access voll übernehmen kann, sondern eine aus Access importierte ….odb-Datei nur öffnen und bearbeiten kann, wenn Access ×64 parallel installiert ist, nützt es mir gar nichts (meine Idee ist, Datenbanken im odb-Format Leuten zur Verfügung zu stellen, die eben MS Access nicht installiert haben) !

Das ist auch der Grund, warum ich mich seit langem nicht gemeldet habe. Vorläufig arbeite ich noch ausschliesslich mit MS Access 2010.

NB: Erstelle ich in Base ….odb aus einer Excel-Tabelle (aus Access exportierte Daten), dann läuft es normal (die Tabellen können geöffnet werden).

< Henri >
Comment 13 Henri 2016-06-09 05:41:57 UTC
PS: Nach der oben beschriebenen Fehlermeldung stürzt LibreOffice Base auch vollständig ab. Das leere, nicht mehr reagierende Fenster lässt sich nur noch über den Windows Task-Manager killen.
< Henri >
Comment 14 Henri 2016-06-09 05:49:13 UTC
PS (2):
Bei einem erneuten Absturz kam folgende Absturz-Info:

Beschreibung:
  Aufgrund eines Problems kann dieses Programm nicht mehr mit Windows kommunizieren.

Problemsignatur:
  Problemereignisname:	AppHangB1
  Anwendungsname:	soffice.bin
  Anwendungsversion:	5.0.6.3
  Anwendungszeitstempel:	572ac309
  Absturzsignatur:	6006
  Absturztyp:	6144
  Betriebsystemversion:	6.1.7601.2.1.0.256.48
  Gebietsschema-ID:	2055
  Zusätzliche Absturzsignatur 1:	60065d711cffc548260f83441f4048b9
  Zusätzliche Absturzsignatur 2:	458d
  Zusätzliche Absturzsignatur 3:	458de2f9bcbd431c9a387b0ec3daab2e
  Zusätzliche Absturzsignatur 4:	6006
  Zusätzliche Absturzsignatur 5:	60065d711cffc548260f83441f4048b9
  Zusätzliche Absturzsignatur 6:	458d
  Zusätzliche Absturzsignatur 7:	458de2f9bcbd431c9a387b0ec3daab2e

Lesen Sie unsere Datenschutzbestimmungen online:
  http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0407

Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
  C:\Windows\system32\de-DE\erofflps.txt