Download it now!
Bug 91200 - Continued crashes
Summary: Continued crashes
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.2.1 rc
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-10 11:50 UTC by Tony
Modified: 2015-12-28 08:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file for crash on C&P (322.88 KB, application/vnd.oasis.opendocument.text)
2015-05-24 18:16 UTC, Carlos Rodriguez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tony 2015-05-10 11:50:17 UTC
LibreOffice v4.4.2 crashes repeatedly, 2-3 times per session without warning. Usually when copying / pasting text or tables. Not always able to recover file. Win7 / Intel Core i3 / Acer Revo / AVG free
Comment 1 Timur 2015-05-11 11:57:30 UTC
Does this happen with a specific file or with all files?
If it's a specific file, please describe exact steps that lead to crash and attach a file.
If random, might be a duplicate of Bug 78429 or Bug 46406. 

Just to be certain the reported issue is not related to corruption in the user profile, could you rename this LibreOffice user directory ( see https://wiki.documentfoundation.org/UserProfile#Default_location or http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/ ) and re-test?
If you still reproduce this randomly with all files, would it be possible you retrieve a backtrace? (see https://wiki.documentfoundation.org/QA/BugReport/Debug_Information#Windows:_How_to_get_a_backtrace)
Comment 2 Buovjaga 2015-05-15 15:14:07 UTC
NEEDINFO while we wait for further information & backtrace.
Comment 3 Tony 2015-05-17 16:14:38 UTC
I have had to remove V4.4.2 completely from the machine as it is my work machine and crashes were so frequent that I simply was not able to tolerate the disruption. I have re-installed V4.3.7.2 and it is perfectly stable. So I conclude that there is a bug somewhere in the changes between 4.3.7 and 4.4.2.
Comment 4 Buovjaga 2015-05-17 16:23:07 UTC
You can install easily multiple LibO versions in parallel with this Windows tool: https://wiki.documentfoundation.org/SI-GUI

Could you try with 4.4.3, when you have time and report here, if it crashes?
Also, a backtrace would be nice, if the crashes still happen.
Comment 5 Carlos Rodriguez 2015-05-24 18:16:32 UTC
Created attachment 115987 [details]
Test file for crash on C&P

I'm not sure if it's the same bug but the symptoms are similar.

Steps to reproduce:
1. Open the attached file
2. Select all from it (Ctrl+A)
3. Copy (Ctrl+C)
4. Create a new one and choose View -> Zoom - Page width
5. Paste (Ctrl+V)
6. Crash

If you choose "Entire page" on View -> Zoom and paste the same info, you don't get the Crash.

I've got this problem on:

Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: es-ES (es_ES.UTF-8)

Debian 8.
Comment 6 Carlos Rodriguez 2015-05-24 18:27:20 UTC
Got this bug also on the following versions but in these cases with a bigger file from a customer that I cannot upload here.

Versión: 4.4.3.2
Id. de compilación: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Configuración regional: es_ES

Versión: 4.3.7.2
Id. de compilación: 8a35821d8636a03b8bf4e15b48f59794652c68ba
Comment 7 Timur 2015-05-25 09:54:06 UTC
(In reply to Carlos Rodriguez from comment #5)
> Created attachment 115987 [details]
> Test file for crash on C&P
> 
> I'm not sure if it's the same bug but the symptoms are similar.

Your bug is well defined and should be reported separately. I did as Bug 91602.
This one shouldn't be changed from Needinfo until clarified.
Comment 8 Tony 2015-05-25 19:19:52 UTC
Happens with a variety of files. The symptoms are that having selected a specific section of the document and hitting CTRL C the application simply crashes and disappears from the screen altogether. Sometimes it occurs when pressing CTRL V.

All files open crash simultaneously. 

The majority of the files were created with Version 4.2 and 4.3 and have been stable on these versions. They are still stable on the machine using V4.3.7.2. When restarting the application it sometimes cannot recover the file and reverts to a previous version. This is even more frustrating as I sometimes lose an hours work.

I also have Libreoffice 4.4.2 installed on a Win7 64 bit machine and this also crashes periodically with the same symptoms.

I am sorry but I can't upload the files as they are typically ~4MB in size (70 - 120 pages) and contain confidential information.
Comment 9 Carlos Rodriguez 2015-05-25 21:23:21 UTC
(In reply to Tony from comment #8)

> I am sorry but I can't upload the files as they are typically ~4MB in size
> (70 - 120 pages) and contain confidential information.

Could you tell us if you've got a lot of headers or footers in your document??

I've got a similar problem with large documents from a customer as yours and found that these files have about 10 footers activated (don't ask me why). If I remove them, then I don't have the C&P problem.

Could it be your problem too???
Comment 10 QA Administrators 2015-12-27 20:31:44 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least
6 months. Please provide the requested information as soon as
possible and mark the bug as UNCONFIRMED. Due to regular bug
tracker maintenance, if the bug is still in NEEDINFO status with
no change in 30 days the QA team will close the bug as INVALID
due to lack of needed information.

For more information about our NEEDINFO policy please read the
wiki located here:
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Status/NEEDINFO

If you have already provided the requested information, please
mark the bug as UNCONFIRMED so that the QA team knows that the
bug is ready to be confirmed.
 
Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team