Bug 91207 - Update style from selection not working
Summary: Update style from selection not working
Status: RESOLVED DUPLICATE of bug 85131
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-10 15:52 UTC by Martin
Modified: 2016-08-05 18:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Autoupdate Heading propagation not working correctly (16.85 KB, application/vnd.oasis.opendocument.text)
2015-05-11 09:27 UTC, Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2015-05-10 15:52:18 UTC
Create style from selection does not retain the proper indention settings. Auto update style doesn't work. Applying the newly created style does not apply correct indention settings to selection. Some style attributes are set others not. Although style is applied consistently.
Comment 1 Jean-Baptiste Faure 2015-05-11 07:12:19 UTC
Please, describe step by step how to reproduce the problem. And provide a test file.

Set status to NEEDINFO. Please, set it back to UNCONFIRMED once you have provided requested informations.

Best regards. JBF
Comment 2 Martin 2015-05-11 09:23:24 UTC
Hi JB,

Since styles don't work reliably in 4.4.3.2 I have switched to LO5alpha1. The bespoke issues are still present. ie:

Paragraph indent setting changes are not propagated correctly with corresponding style they seem to be part of direct formatting. The same is true for numbered and bulleted lists and possibly others. (I personally think ALL paragraph settings except direct formatting should be part of the style.) 

Furthermore, applying new paragraph indent settings to style with autoupdate enabled propagates correctly to paragraph with same style but NOT to the style selected. See test case: 

Select first header 1 style in document. Right click mouse open paragraph window, change indent settings. 
>> SECOND header 1 paragraph is changed correctly FIRST header 1 style is NOT changed.

As a result style handling gets messed up and becomes useless... 

Regards,
Comment 3 Martin 2015-05-11 09:27:04 UTC
Created attachment 115488 [details]
Autoupdate Heading propagation not working correctly
Comment 4 pierre-yves samyn 2015-05-23 17:56:38 UTC
Hi

I reproduce on windows 7/64 & Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fr_FR

Also reproduced with Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: fr-FR (fr_FR)

Steps to reproduce:
1. File> New> Text Document
2. Type Heading1<Enter>Heading1<Enter>

Expected & actual results: 2 paragraphs with text "Heading1"

3. Edit> Select All
4. Ctrl+1 (or apply Heading1, paragraph style from style window)
5. Right click> Edit Paragraph Style, Organizer tab, check AutoUpdate, OK
6. Un-select all, right click first paragraph> Paragraph
7. "Indent & Spacing" tab, Before text: -2, Ok

Expected result: two paragraph apply same indent.
Actual result: only the second paragaph applies indent.

I set status to New and update summary (change "Create" for "Update")

Regards
Pierre-Yves
Comment 5 Hans Deragon 2015-05-25 21:06:06 UTC
I confirm the bug, following instructions provided by Pierre-Yves Samyn.

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: en_US
Comment 6 Buovjaga 2016-08-05 18:48:01 UTC

*** This bug has been marked as a duplicate of bug 85131 ***