Download it now!
Bug 91229 - Anomalies applying conditional formatting (LO Calc 4.4.3.2).
Summary: Anomalies applying conditional formatting (LO Calc 4.4.3.2).
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2015-05-11 20:08 UTC by gmarco
Modified: 2017-05-18 07:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screen case 1a (47.62 KB, image/jpeg)
2015-05-11 20:08 UTC, gmarco
Details
screen case 2a (81.64 KB, image/jpeg)
2015-05-11 20:10 UTC, gmarco
Details
screen case 2b (93.34 KB, image/jpeg)
2015-05-11 20:10 UTC, gmarco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gmarco 2015-05-11 20:08:31 UTC
Created attachment 115504 [details]
screen case 1a

I have identified some states of apparent anomaly, easily reproducible (I can do it at infinity), on which you should be able to investigate.

-1-) Create a new sheet and enter the values and formulas (A1 =230, A2 =225, A3 =A1-A2), copy col.A into col.B, creates a style and apply the conditional formatting ("Format-Conditional Formatting") on A3 (if = 5 "red backgrounded"), do the same thing with B3;
now you can try and try to change the conditions in B3 and A3 and the result will get always correct.

-1a-) creates a new sheet as above, applies the conditional formatting on A3 and then copy it to B3 using "Copy - Paste special-formats" as exemplified in the help '"https://help.libreoffice.org/Calc/Applying_Conditional_Formatting"  Step 5: Copy Cell Style';
now try to change the condition in B3 (if = 0), you will notice that the result is not changed (see attached "case1a.jpg") and, continuing to change the condition of B3, the result will always remain wrong until you change the condition of A3 (it is sufficient to open the window of "Conditional Formatting" and, even without changing anything, clicking OK).
I further notice that, saving the file (as xls or ods) in the wrong state and reopening it, the cell B3 too displays now correctly and its conditional formatting can be changed without problems.

-2-) Create a new sheet and enter the values and formulas (A1 =230, A2 =225, A3 =A1-A2), copy A1/A3 to A5/A7 and to A9/A11 then copy col.A to col.B and to col.C, creates a style and apply the conditional formatting ("Format-Conditional Formatting") on A3 (if = 5 "red backgrounded");
copy it to B3 C3 A7 B7 C7 A11 B11 C11 (select A3 - copy - select B3 and Ctrl+ C3 A7 B7 ... - paste special-formats);
go to "Conditional Formatting-Manage Conditional Formatting" and the window shows only A3 A7 A11 B3 (see attached "case2a.jpg").
Now, trying to change the condition of C3, a warning window will appear (see attached "case2b.jpg"; note: image displays LO 4.3.7.2 but the same gets in LO 4.4.3.2) that does not appear if you change the condition of B3 (these are only 
examples, you can prove this even with other cells); however the result in B3 does not change anyway (as already observed at point 1a).
From this point (trying to change the condition of C3) my test takes different ways (warning: for every testing way you must restart from a new base sheet):

w1 --- replying NO from the warning window,  the "Condition" window is nevertheless displayed and you can see that the cell really has no conditional formatting; now,  if you apply one, that is acquired but the displayed outcome is unchanged (as already observed at point 1a).

w2 --- replying YES from the warning window,  the "Condition" window is displayed and you can see that the cell seems having the condition applied; now,  if you change that one, the new condition is acquired and the displayed outcome appears correct, but looking at "Manage Conditional Formatting" window the cell C3 is not displayed.

w3 --- trying the same as above on cell B11 (instead of C3) other strangeness happen (but, at this point, I think unusefull going any further ....).

w4 --- in reality, cells B7 B11 C3-7-11 have not been conditioned: you get the proof saving/reopening the file; that cells get no more  "red backgrounded" and have no conditional formatting, while B3 displays correctly conditioned and you 
can change successfully its conditional formatting (as already observed at point 1a).

In conclusion I think something has to be revised about this area.
I don't think all this happens to me only, for that I'll be gratefull if someone other could reproduce and confirm.
Comment 1 gmarco 2015-05-11 20:10:03 UTC
Created attachment 115505 [details]
screen case 2a
Comment 2 gmarco 2015-05-11 20:10:58 UTC
Created attachment 115506 [details]
screen case 2b
Comment 3 Buovjaga 2015-05-15 16:18:04 UTC
Did you really test with 4.4.3? Because your screen case 2b says 4.3.7.2.
I could not reproduce case 1a in 4.4.3.

Set to NEEDINFO.
Change back to UNCONFIRMED after you have confirmed the version information.

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI
Comment 4 Buovjaga 2015-05-15 16:31:34 UTC
Now I noticed, that if I edit the conditional formatting of B3 and remove it, it was still formatted with a red bg. I edited it again and got this messagE:

The selected cell already contains conditional formatting. You can either edit the existing conditional format or you define a new overlapping conditional format.

Do you want to edit the existing conditional format?

After selecting yes it displayed the condition for A3. Removing it removed it for A3 also.

I seem to have been testing with 5.0 alpha1 instead of 4.4.3.

I'll set this to NEW for case 1a.

You should create a new report for case 2 as we only have 1 bug per report.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+
Build ID: 9de1d53a2ce3ee7036b4688b373db7b2235af4d9
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-14_00:07:12
Locale: fi-FI (fi_FI)
Comment 5 gmarco 2015-05-15 17:53:10 UTC
(In reply to Beluga from comment #3)
> Did you really test with 4.4.3? Because your screen case 2b says 4.3.7.2.
> I could not reproduce case 1a in 4.4.3.
> 
> Set to NEEDINFO.
> Change back to UNCONFIRMED after you have confirmed the version information.
> 
> Win 7 Pro 64-bit, Version: 4.4.3.2
> Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
> Locale: fi_FI

Hi Beluga, I confirm I am using and testing 4.4.3.2 (Win 8.1 x86) as said in the note about.
Screen case 2b shows 4.3.7.2 having I previously verified and documented the problem in the old version, but, beeing it still in the last, I reported attaching the previous document.
Comment 6 gmarco 2015-05-15 20:46:41 UTC
(In reply to Beluga from comment #4)
> Now I noticed, that if I edit the conditional formatting of B3 and remove
> it, it was still formatted with a red bg. I edited it again and got this
> messagE:
> 
> The selected cell already contains conditional formatting. You can either
> edit the existing conditional format or you define a new overlapping
> conditional format.
> 
> Do you want to edit the existing conditional format?
> 
> After selecting yes it displayed the condition for A3. Removing it removed
> it for A3 also.
> 
> I seem to have been testing with 5.0 alpha1 instead of 4.4.3.
> 
> I'll set this to NEW for case 1a.
> 
> You should create a new report for case 2 as we only have 1 bug per report.
> 
> Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+
> Build ID: 9de1d53a2ce3ee7036b4688b373db7b2235af4d9
> TinderBox: Win-x86@39, Branch:master, Time: 2015-05-14_00:07:12
> Locale: fi-FI (fi_FI)

As requested, bug 91312 created for case 2.
Comment 7 QA Administrators 2016-09-20 10:29:24 UTC Comment hidden (obsolete)
Comment 8 gmarco 2016-09-21 17:16:38 UTC
LO 5.2.1.2 Win10
bug still present, nothing has changed
Comment 9 gmarco 2017-05-18 07:35:09 UTC
In LO 5.3.3.2 appears OK, you may change to FIXED.
Comment 10 Buovjaga 2017-05-18 07:49:58 UTC
Ok, let's assume this was fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?id=8a11d34c7e08218b5ff9da4870c460297f312332 as well.

Thank you for following through.