Download it now!
Bug 91279 - Password Prompt not in focus
Summary: Password Prompt not in focus
Status: RESOLVED DUPLICATE of bug 49134
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-14 03:30 UTC by Todd
Modified: 2015-11-08 23:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todd 2015-05-14 03:30:07 UTC
LibreOffice_4.4.3_Linux_x86-64_rpm.tar.gz
4.4.3 general release was not in the version selection (or I could not find it)

Dear Libre Office,

Would one of our intrepid heroes please fix this for me?

I have several encrypted file (odt) that I use with Writer.  When I open the file(s), LO give me a pop up to enter the password.

Problem: 9 times out of 10, the prompt is not in focus (the decoration is gray instead of blue).  I proceed to enter my long, complex passwords into the ether; realize the prompt is not in focus when nothing happens after I press Enter; click on the prompt to put it in focus; then enter my long, complex passwords a second time.

Would you guys do your magic and get the prompt to pop up in focus so I don't keep having to enter my passwords twice?

Many thanks,
-T
Comment 1 Buovjaga 2015-05-18 10:27:09 UTC
Are you still using Xfce? :)

Could not reproduce with 4.3.5.2 or 5.0.0.0.alpha1+
Build ID: bcbf45d9f94d177c6841ccede3ff0ba69c4f22b1
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-04_03:51:16
Locale: fi-FI (fi_FI.UTF-8)

Scientific Linux 7 64-bit, Xfce 4.10.

Could not repro on Ubuntu 15.04 with 5.0 alpha1 built yesterday either.
Comment 2 Todd 2015-05-19 00:01:46 UTC
(In reply to Beluga from comment #1)
> Are you still using Xfce? :)
> 
> Could not reproduce with 4.3.5.2 or 5.0.0.0.alpha1+
> Build ID: bcbf45d9f94d177c6841ccede3ff0ba69c4f22b1
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-05-04_03:51:16
> Locale: fi-FI (fi_FI.UTF-8)
> 
> Scientific Linux 7 64-bit, Xfce 4.10.
> 
> Could not repro on Ubuntu 15.04 with 5.0 alpha1 built yesterday either.


$ rpm -qa xfce\*
xfce4-session-engines-4.8.1-4.el6.x86_64
...

$ cat /etc/redhat-release
Scientific Linux release 6.6 (Carbon)

I am *STUCK* with EL6, as EL7 does not support Wine32, making EL7 worthless.  (I had SL7 installed for a time, and really adored it, but had to rip it off over the Wine 32 problem.  And RH is not budging on the issue.)

This is the only pop up that doesn't come up in focus.  As far as I can reproduce it, it depends on if I move the mouse off the the click point before the pop up actually pops up.
Comment 3 Buovjaga 2015-05-19 05:43:29 UTC
(In reply to Todd from comment #2)
> $ rpm -qa xfce\*
> xfce4-session-engines-4.8.1-4.el6.x86_64
> ...
> 
> $ cat /etc/redhat-release
> Scientific Linux release 6.6 (Carbon)
> 
> I am *STUCK* with EL6, as EL7 does not support Wine32, making EL7 worthless.
> (I had SL7 installed for a time, and really adored it, but had to rip it off
> over the Wine 32 problem.  And RH is not budging on the issue.)
> 
> This is the only pop up that doesn't come up in focus.  As far as I can
> reproduce it, it depends on if I move the mouse off the the click point
> before the pop up actually pops up.

Yep, it might not be because of the Xfce version, but did you try the Wine 32 compilation on SL 7: https://www.centos.org/forums/viewtopic.php?f=48&t=49542
I made some mistakes myself in compiling omitting some steps, but at least one person reported they got it working on SL 7.

Btw. Xfce 4.12 is being packaged for EPEL 7.
Comment 4 Todd 2015-05-19 06:12:49 UTC
(In reply to Beluga from comment #3)
> but did you try the Wine
> 32 compilation on SL 7:
> https://www.centos.org/forums/viewtopic.php?f=48&t=49542


I have looked at that several times.  What a nightmare.  I even asked EPEL if they would use that link to support Wine 32.  At least they were nice when they said "no".

I have also asked Xfce if they would stop using cutting edge dependencies.  They were nice when they said "no" too.
Comment 5 Todd 2015-05-22 18:55:31 UTC
Hi All,

Every tie I start Thunderbird, I get two password pop ups.  They always stay in focus.  What are they doing different that you?


-T
Comment 6 Adolfo Jayme 2015-11-08 23:49:45 UTC
Hi, Todd:

This bug looks like a dupe of the annoying 49134. =)

*** This bug has been marked as a duplicate of bug 49134 ***