Download it now!
Bug 91290 - FORMATTING Memory/Thread crash
Summary: FORMATTING Memory/Thread crash
Status: RESOLVED DUPLICATE of bug 90757
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-14 16:17 UTC by sstory
Modified: 2015-05-14 22:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of one of the errors (14.17 KB, image/jpeg)
2015-05-14 16:27 UTC, sstory
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sstory 2015-05-14 16:17:38 UTC
With a spreadsheet with 57080 rows and 15 columns, I encountered a Fatal error more than once while trying to Search and Replace (Replace All) within selection (selected the entire column) using regular expressions, searching for ^. and replacing with &. This was to get rid of the leading apostrophe in a date column of data imported from a tab separated file.
The error occurring seemed to be some sort of memory allocation issue.
This is a on a Windows 7 64bit machine with 12GB of RAM.

Also in attempting to format that same column to a custom date of YYYY MMMM-DD
I got an error that said something about osl thread create failed.

It also failed once when I got the date to convert, but then did a left justify on the column.
Comment 1 sstory 2015-05-14 16:24:49 UTC
If it makes any difference, the document in one a samba network share.
Comment 2 sstory 2015-05-14 16:27:51 UTC
Created attachment 115604 [details]
Screenshot of one of the errors
Comment 3 sstory 2015-05-14 16:58:10 UTC
I've discovered that selecting the column and doing Data->Text to Column does the same thing when trying to get rid of the leading ' so that the column can be formatted as a date.
Comment 4 m.a.riosv 2015-05-14 22:25:30 UTC
I think it was solved with https://bugs.documentfoundation.org/show_bug.cgi?id=90757
also the issue selecting the entire column.

With that regex all cell content is lost. Try with search .* and replace &

*** This bug has been marked as a duplicate of bug 90757 ***