Bug 91322 - Breeze icon set with dark theme
Summary: Breeze icon set with dark theme
Status: RESOLVED DUPLICATE of bug 94632
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-16 09:40 UTC by Heiko Tietze
Modified: 2016-09-16 13:32 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
LO 4.4.3.2, KDE with Wonton Soup, Sifr icon set (17.07 KB, image/png)
2015-05-16 09:40 UTC, Heiko Tietze
Details
LO 5.0.0.0.alpha1, KDE with Wonton Soup, Breeze icons (11.76 KB, image/png)
2015-05-16 09:42 UTC, Heiko Tietze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2015-05-16 09:40:43 UTC
Created attachment 115653 [details]
LO 4.4.3.2, KDE with Wonton Soup, Sifr icon set

Breeze looks nice with 'normal' bright colors but is barely readable in case of darker backgrounds (e.g. Wonton Soup at KDE). The same is true for other monochrome icon sets like Sifr. The ux group discussed the adjustment of white/grey colors automatically as a possible solution. Another way to deal with the situation is to read icons from the system.
Comment 1 Heiko Tietze 2015-05-16 09:42:51 UTC
Created attachment 115654 [details]
LO 5.0.0.0.alpha1, KDE with Wonton Soup, Breeze icons
Comment 2 Adolfo Jayme Barrientos 2015-05-16 14:37:36 UTC
The dark set has been created in the upstream icon repo at GitHub: https://github.com/NitruxSA/plasma-next-icons/pull/139
Comment 3 Heiko Tietze 2015-05-16 18:03:55 UTC
Adding the Breeze Dark icon set clutters the LO dialog too much. That's why Kendy suggested to solve the issue programmatically.

BTW: Better pull from git://anongit.kde.org/breeze.git
Comment 4 Adolfo Jayme Barrientos 2015-10-12 13:15:47 UTC
Work on this has commenced, see http://cgit.freedesktop.org/libreoffice/core/commit/?id=78a4e9cb89830191e77c558759e845e5a15b9cc7

Jay filed a duplicate that is more general (includes Sifr).

*** This bug has been marked as a duplicate of bug 94632 ***
Comment 5 Marco Martin 2016-09-16 13:32:09 UTC
just adding a comment on how a Plasma sessions colors the Breeze icons:

for its monochrome icons, that icon theme internally uses stylesheets to apply the colors.

very simplified the source svg of a typical breeze icon looks like:
  <defs
     id="defs3051">
    <style
       id="current-color-scheme"
       type="text/css">
      .ColorScheme-Text {
        color:#31363b;
      }
      </style>
  </defs>

   <path
       id="path7"
       class="ColorScheme-Text"
       d="... "
       style="fill:currentColor;fill-opacity:1;stroke:none" />

(other named colors are supported besides Text)
then our icon loader changes the contents of the "current-color-scheme" element before rendering the icon, making it easy to paint them with different colors.

Maybe Libreoffice could do something like that? (either directly loaded at build time, prerendered at build time or whatever)